summaryrefslogtreecommitdiff
path: root/br-ext/package/optee_test_ext/optee_test_ext.mk
diff options
context:
space:
mode:
authorJerome Forissier <jerome@forissier.org>2020-11-10 17:24:05 +0100
committerJérôme Forissier <jerome@forissier.org>2020-11-17 15:04:41 +0100
commit0170c6c7c34ce6e5b59d6ffd54cdba32527659fc (patch)
treefb46d18775cb77b33618dba791edf61abbe91a69 /br-ext/package/optee_test_ext/optee_test_ext.mk
parent1c146e437b0bcdf1c41a14183abd5e853395f828 (diff)
Introduce BR2_PACKAGE_OPTEE_TEST_EXT_WITH_CXX_TESTS
Conditionally enable TA C++ tests in the optee_test_ext Buildroot package. Some toolchains may not support this feature [1] so it is best to let the user decide. common.mk enables the tests by default when $(COMPILER) is not clang, assuming that the default GCC toolchain from toolchain.mk is used (which works fine with the C++ tests). The command line option is 'make WITH_CXX_TESTS=y|n'. Link: https://github.com/OP-TEE/optee_test/issues/458 Signed-off-by: Jerome Forissier <jerome@forissier.org> Acked-by: Etienne Carriere <etienne.carriere@linaro.org> Acked-by: Jens Wiklander <jens.wiklander@linaro.org>
Diffstat (limited to 'br-ext/package/optee_test_ext/optee_test_ext.mk')
-rw-r--r--br-ext/package/optee_test_ext/optee_test_ext.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/br-ext/package/optee_test_ext/optee_test_ext.mk b/br-ext/package/optee_test_ext/optee_test_ext.mk
index b05d0a0..5476fc8 100644
--- a/br-ext/package/optee_test_ext/optee_test_ext.mk
+++ b/br-ext/package/optee_test_ext/optee_test_ext.mk
@@ -19,6 +19,10 @@ ifneq ($(BR2_PACKAGE_OPTEE_TEST_EXT_WITH_TLS_TESTS),)
TARGET_CONFIGURE_OPTS += WITH_TLS_TESTS=$(BR2_PACKAGE_OPTEE_TEST_EXT_WITH_TLS_TESTS)
endif
+ifneq ($(BR2_PACKAGE_OPTEE_TEST_EXT_WITH_CXX_TESTS),)
+TARGET_CONFIGURE_OPTS += WITH_CXX_TESTS=$(BR2_PACKAGE_OPTEE_TEST_EXT_WITH_CXX_TESTS)
+endif
+
define OPTEE_TEST_EXT_PREPARE_GP_SUITE
sh $(@D)/host/xtest/gp/prepare_suite.sh $(@D) \
$(BR2_PACKAGE_OPTEE_TEST_EXT_GP_PACKAGE)