summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2018-02-15 15:49:26 +0000
committerDaniel Díaz <daniel.diaz@linaro.org>2018-02-15 12:35:10 -0600
commitd60b1a44c89e9e9db3ed0bdc8cdabaca8a6ff4c5 (patch)
treecaf4a79d3c94b21de5f003bf9e519def3c443144
parentd581d89b317fedd146b3c006fbe0e3f9acfd6b11 (diff)
meta-ilp32: edk2-hikey: refresh patches for lp64
Rebase edk2 to 8c9e0d9bc5582ca1f4d7bc14c11c1ae4831c0118. Rebase ATF to 10787b0519afce1e887a935789b2d624849856a9. Change-Id: I70d7b38ec28530a9dffbaba19b55bc1ae336210f Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
-rw-r--r--meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-atf-set-flag-to-build-in-lp64-mode-for-ilp32-toolcha.patch13
-rw-r--r--meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-include-common-asm_macros-update-to-build-with-GAS-2.patch10
-rw-r--r--meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-set-flag-to-build-in-lp64-mode-for-ilp32-toolchain.patch9
3 files changed, 19 insertions, 13 deletions
diff --git a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-atf-set-flag-to-build-in-lp64-mode-for-ilp32-toolcha.patch b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-atf-set-flag-to-build-in-lp64-mode-for-ilp32-toolcha.patch
index a5fe541..1173544 100644
--- a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-atf-set-flag-to-build-in-lp64-mode-for-ilp32-toolcha.patch
+++ b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-atf-set-flag-to-build-in-lp64-mode-for-ilp32-toolcha.patch
@@ -2,6 +2,9 @@ From ea77365555ff752735a1507570e737367f235064 Mon Sep 17 00:00:00 2001
From: Vishal Bhoj <vishal.bhoj@linaro.org>
Date: Fri, 15 Sep 2017 12:05:09 +0100
Subject: [PATCH] atf:set flag to build in lp64 mode for ilp32 toolchain
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
Signed-off-by: Vishal Bhoj <vishal.bhoj@linaro.org>
Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
@@ -10,17 +13,17 @@ Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/atf/Makefile b/atf/Makefile
-index 6fb10b76..24016366 100644
+index ee22752..5a2fb5e 100644
--- a/atf/Makefile
+++ b/atf/Makefile
-@@ -137,13 +137,13 @@ TF_CFLAGS_aarch32 = -march=armv8-a
+@@ -152,13 +152,13 @@ TF_CFLAGS_aarch32 = $(march32-directive)
TF_CFLAGS_aarch64 = -march=armv8-a
endif
-TF_CFLAGS_aarch64 += -mgeneral-regs-only -mstrict-align
+TF_CFLAGS_aarch64 += -mgeneral-regs-only -mstrict-align -Wno-error -mabi=lp64
- ASFLAGS_aarch32 = -march=armv8-a
+ ASFLAGS_aarch32 = $(march32-directive)
-ASFLAGS_aarch64 = -march=armv8-a
+ASFLAGS_aarch64 = -march=armv8-a -mabi=lp64
@@ -30,14 +33,14 @@ index 6fb10b76..24016366 100644
ASFLAGS += $(CPPFLAGS) $(ASFLAGS_$(ARCH)) \
-D__ASSEMBLY__ -ffreestanding \
-Wa,--fatal-warnings
-@@ -153,6 +153,7 @@ TF_CFLAGS += $(CPPFLAGS) $(TF_CFLAGS_$(ARCH)) \
+@@ -175,6 +175,7 @@ endif
TF_LDFLAGS += --fatal-warnings -O1
TF_LDFLAGS += --gc-sections
+TF_LDFLAGS += -m aarch64elf
TF_LDFLAGS += $(TF_LDFLAGS_$(ARCH))
- ################################################################################
+ DTC_FLAGS += -I dts -O dtb
--
2.7.4
diff --git a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-include-common-asm_macros-update-to-build-with-GAS-2.patch b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-include-common-asm_macros-update-to-build-with-GAS-2.patch
index 9b2af69..27f70bd 100644
--- a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-include-common-asm_macros-update-to-build-with-GAS-2.patch
+++ b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-include-common-asm_macros-update-to-build-with-GAS-2.patch
@@ -32,22 +32,22 @@ Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/common/aarch64/asm_macros.S b/include/common/aarch64/asm_macros.S
-index 6d6989c..fc3384e 100644
+index 94a9df9..91c0b9e 100644
--- a/atf/include/common/aarch64/asm_macros.S
+++ b/atf/include/common/aarch64/asm_macros.S
@@ -53,7 +53,7 @@
*/
- .macro vector_base label
- .section .vectors, "ax"
+ .macro vector_base label, section_name=.vectors
+ .section \section_name, "ax"
- .align 11, 0
+ .align 11
\label:
.endm
@@ -67,7 +67,7 @@
- .macro vector_entry label
+ .macro vector_entry label, section_name=.vectors
.cfi_sections .debug_frame
- .section .vectors, "ax"
+ .section \section_name, "ax"
- .align 7, 0
+ .align 7
.type \label, %function
diff --git a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-set-flag-to-build-in-lp64-mode-for-ilp32-toolchain.patch b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-set-flag-to-build-in-lp64-mode-for-ilp32-toolchain.patch
index 3f68ab6..6fcc956 100644
--- a/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-set-flag-to-build-in-lp64-mode-for-ilp32-toolchain.patch
+++ b/meta-ilp32/recipes-overlayed/edk2-hikey/edk2-hikey/0001-set-flag-to-build-in-lp64-mode-for-ilp32-toolchain.patch
@@ -2,6 +2,9 @@ From 385b3e2f88d94b07471af68a66a838f727e76307 Mon Sep 17 00:00:00 2001
From: Vishal Bhoj <vishal.bhoj@linaro.org>
Date: Fri, 15 Sep 2017 12:04:13 +0100
Subject: [PATCH] set flag to build in lp64 mode for ilp32 toolchain
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
Signed-off-by: Vishal Bhoj <vishal.bhoj@linaro.org>
Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
@@ -10,15 +13,15 @@ Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/BaseTools/Conf/tools_def.template b/BaseTools/Conf/tools_def.template
-index 1e05d0c959..b0360f12d5 100644
+index 497f6d8..9046c0b 100755
--- a/BaseTools/Conf/tools_def.template
+++ b/BaseTools/Conf/tools_def.template
@@ -4341,7 +4341,7 @@ DEFINE GCC_X64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mno-red-zone -Wno-ad
DEFINE GCC_IPF_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -minline-int-divide-min-latency
DEFINE GCC_ARM_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -mabi=aapcs -fno-short-enums -funsigned-char -ffunction-sections -fdata-sections -fomit-frame-pointer -fno-builtin -Wno-address -mthumb -mfloat-abi=soft
DEFINE GCC_ARM_CC_XIPFLAGS = -mno-unaligned-access
--DEFINE GCC_AARCH64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -fno-short-enums -fverbose-asm -funsigned-char -ffunction-sections -fdata-sections -fno-builtin -Wno-address -fno-asynchronous-unwind-tables
-+DEFINE GCC_AARCH64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -fno-short-enums -fverbose-asm -funsigned-char -ffunction-sections -fdata-sections -fno-builtin -Wno-address -fno-asynchronous-unwind-tables -mabi=lp64 -Wno-error
+-DEFINE GCC_AARCH64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -fno-short-enums -fverbose-asm -funsigned-char -ffunction-sections -fdata-sections -fno-builtin -Wno-address -fno-asynchronous-unwind-tables -fno-pic -fno-pie -ffixed-x18
++DEFINE GCC_AARCH64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -fno-short-enums -fverbose-asm -funsigned-char -ffunction-sections -fdata-sections -fno-builtin -Wno-address -fno-asynchronous-unwind-tables -fno-pic -fno-pie -ffixed-x18 -mabi=lp64 -Wno-error
DEFINE GCC_AARCH64_CC_XIPFLAGS = -mstrict-align
DEFINE GCC_DLINK_FLAGS_COMMON = -nostdlib --pie
DEFINE GCC_DLINK2_FLAGS_COMMON = -Wl,--script=$(EDK_TOOLS_PATH)/Scripts/GccBase.lds