summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-06-13 22:30:24 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-06-13 22:31:10 -0300
commitca572aef070bae88efea494e84102bd2d5749aae (patch)
tree0f6362c2305aa21b75b5d63565fd782ee3961c82
parent2d9e3a29b534f07c84a7007607005679001a04db (diff)
docker-init: remove recipe, now part of meta-virtualization
No need to maintain a local version of docker-init now that it was merged as part of the meta-virtualization layer. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
-rw-r--r--recipes-containers/docker/docker-init/dont_strip_by_default.patch13
-rw-r--r--recipes-containers/docker/docker-init_git.bb26
-rw-r--r--recipes-containers/docker/docker_%.bbappend2
3 files changed, 0 insertions, 41 deletions
diff --git a/recipes-containers/docker/docker-init/dont_strip_by_default.patch b/recipes-containers/docker/docker-init/dont_strip_by_default.patch
deleted file mode 100644
index 6f25b14..0000000
--- a/recipes-containers/docker/docker-init/dont_strip_by_default.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b5b93ba..c2907e2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -54,7 +54,7 @@ if(NOT HAS_BUILTIN_FORTIFY)
- endif()
-
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Werror -Wextra -Wall -pedantic-errors -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat")
--set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-s")
-+set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-Bsymbolic-functions -Wl,-z,relro")
-
- # Build
-
diff --git a/recipes-containers/docker/docker-init_git.bb b/recipes-containers/docker/docker-init_git.bb
deleted file mode 100644
index 3feba1e..0000000
--- a/recipes-containers/docker/docker-init_git.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "A tiny but valid init for containers (used as docker-init)"
-HOMEPAGE = "https://github.com/krallin/tini"
-DESCRIPTION = "Tini is a simple init that spawns a single child and \
- wait for it to exit all the while reaping zombies and performing signal \
- forwarding. Docker uses tini as the default container init process."
-SECTION = "devel"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ffc9091894702bc5dcf4cc0085561ef5"
-
-SRCREV = "949e6facb77383876aeff8a6944dde66b3089574"
-SRC_URI = "\
- git://github.com/krallin/tini.git \
- file://dont_strip_by_default.patch \
- "
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-OECMAKE_TARGET_COMPILE = "tini-static"
-
-do_install() {
- mkdir -p ${D}/${bindir}
- cp ${B}/tini-static ${D}/${bindir}/docker-init
-}
diff --git a/recipes-containers/docker/docker_%.bbappend b/recipes-containers/docker/docker_%.bbappend
index 2b611f5..66817bd 100644
--- a/recipes-containers/docker/docker_%.bbappend
+++ b/recipes-containers/docker/docker_%.bbappend
@@ -1,3 +1 @@
-RDEPENDS_${PN} += "docker-init"
-
INHIBIT_PACKAGE_STRIP = "0"