summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-03-28 15:41:58 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-04-02 13:28:49 -0300
commit78b57c105d2f4462f63b1fdaffa6908883be260f (patch)
tree86dae8850a5597913e48e3414312c301b3314329 /recipes-core
parentaa52278141c8a2d7ecf1051af1ce99809af54380 (diff)
dbus: make sure /var/lib/dbus/ gets created during boot
Backport upstream fix for the lack of /var/lib/dbus/ during boot. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/dbus/dbus/backport-modify-systemd-tmpfiles.d-create-var_lib_dbus.patch37
-rw-r--r--recipes-core/dbus/dbus_%.bbappend5
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-core/dbus/dbus/backport-modify-systemd-tmpfiles.d-create-var_lib_dbus.patch b/recipes-core/dbus/dbus/backport-modify-systemd-tmpfiles.d-create-var_lib_dbus.patch
new file mode 100644
index 0000000..fdf9d96
--- /dev/null
+++ b/recipes-core/dbus/dbus/backport-modify-systemd-tmpfiles.d-create-var_lib_dbus.patch
@@ -0,0 +1,37 @@
+From 49c6c6196639118a06c736cee39a745521bcf34d Mon Sep 17 00:00:00 2001
+From: Chris Lesiak <chris.lesiak@licor.com>
+Date: Wed, 10 Jan 2018 15:35:20 -0600
+Subject: Modify systemd tmpfiles.d snippet to create /var/lib/dbus/
+
+This snippet was already attempting to create /var/lib/dbus/machine-id,
+but would fail on volatile or stateless systems where /var/lib/dbus/
+did not already exist. systemd-tmpfiles automatically creates parent
+directories for tmpfiles of type 'd', 'D', etc., but not for files
+or symlinks (https://github.com/systemd/systemd/issues/7853).
+
+Signed-off-by: Chris Lesiak <chris.lesiak@licor.com>
+[smcv: Extended commit message to clarify why we need this]
+Bug: https://bugs.freedesktop.org/show_bug.cgi?id=104577
+Reviewed-by: Simon McVittie <smcv@collabora.com>
+(cherry picked from commit aeebf801f1ab462cba3a174440c09a86d326002a)
+---
+ bus/tmpfiles.d/dbus.conf.in | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/bus/tmpfiles.d/dbus.conf.in b/bus/tmpfiles.d/dbus.conf.in
+index 754f022..664d53a 100644
+--- a/bus/tmpfiles.d/dbus.conf.in
++++ b/bus/tmpfiles.d/dbus.conf.in
+@@ -1,5 +1,9 @@
+ # Fields: type; path; mode; uid; gid; age; argument (symlink target)
+
++# Make ${localstatedir}/lib/dbus/
++# Adjust mode and ownership if it already exists.
++d @EXPANDED_LOCALSTATEDIR@/lib/dbus 0755 - - -
++
+ # Make ${localstatedir}/lib/dbus/machine-id a symlink to /etc/machine-id
+ # if it does not already exist
+ L @EXPANDED_LOCALSTATEDIR@/lib/dbus/machine-id - - - - /etc/machine-id
+--
+cgit v1.1
+
diff --git a/recipes-core/dbus/dbus_%.bbappend b/recipes-core/dbus/dbus_%.bbappend
new file mode 100644
index 0000000..02e2ed7
--- /dev/null
+++ b/recipes-core/dbus/dbus_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append += " \
+ file://backport-modify-systemd-tmpfiles.d-create-var_lib_dbus.patch \
+"