summaryrefslogtreecommitdiff
path: root/binutils/configure.ac
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2019-06-03 16:28:15 +0100
committerNick Clifton <nickc@redhat.com>2019-06-03 16:28:15 +0100
commit79b377b3cf3a0e71e1e4710c4ee1e65e7a27a5d4 (patch)
treea3a53be8e92d9a1dc842a20f2624959f55ca2e80 /binutils/configure.ac
parent4f6d070adb32e61c3c61e621c6566fc2d5af2232 (diff)
Revert patch that disables building libctf for non-ELF based targets.
Revert: binutls 2019-05-29 Nick Clifton <nickc@redhat.com> * configure.ac (LIBCTF): Export. Set to empty for non-ELF based targets. (HAVE_LIBCTF): Define if libctf support is available. * Makefile.am (LIBCTF): Set value to @LIBCTF@. * objdump.c: Make CTF code conditional upon HAVE_LIBCTF being defined. * readelf.c: Likewise. * configure: Regenerate. * Makefile.in: Regenerate. * config.in: Regenerate. top 2019-05-29 Nick Clifton <nickc@redhat.com> * configure.ac (noconfigdirs): Add libctf if the target does not use the ELF file format. * configure: Regenerate.
Diffstat (limited to 'binutils/configure.ac')
-rw-r--r--binutils/configure.ac30
1 files changed, 0 insertions, 30 deletions
diff --git a/binutils/configure.ac b/binutils/configure.ac
index 71be51e6a6..b1cd4552f2 100644
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
@@ -393,35 +393,6 @@ changequote([,])dnl
fi
done
-
-AC_MSG_CHECKING([for libctf support])
-case "${target}" in
- *-*-pe | *-*-*vms* | *-*-darwin | *-*-*coff* | *-*-wince | *-*-mingw*)
- AC_CACHE_VAL(bu_cv_libctf_support, bu_cv_libctf_support=no)
- ;;
- *-*-aout | *-*-osf* | *-*-go32 | *-*-macos* | *-*-rhapsody*)
- AC_CACHE_VAL(bu_cv_libctf_support, bu_cv_libctf_support=no)
- ;;
- *-*-netbsdpe | *-*-cygwin* | *-*-pep | *-*-msdos | *-*-winnt)
- AC_CACHE_VAL(bu_cv_libctf_support, bu_cv_libctf_support=no)
- ;;
- ns32k-*-* | pdp11-*-* | *-*-aix* | *-*-netbsdaout)
- AC_CACHE_VAL(bu_cv_libctf_support, bu_cv_libctf_support=no)
- ;;
- *)
- AC_CACHE_VAL(bu_cv_libctf_support, bu_cv_libctf_support=yes)
- ;;
-esac
-AC_MSG_RESULT($bu_cv_libctf_support)
-if test $bu_cv_libctf_support = yes; then
- AC_DEFINE(HAVE_LIBCTF, 1, [Is libctf available?])
-fi
-LIBCTF=
-if test $bu_cv_libctf_support = yes; then
- LIBCTF=../libctf/libctf.a
-fi
-
-
# Uniq objdump private vector, build objdump target ofiles.
od_files=
f=""
@@ -478,7 +449,6 @@ AC_SUBST(BUILD_MISC)
AC_SUBST(BUILD_INSTALL_MISC)
AC_SUBST(OBJDUMP_DEFS)
AC_SUBST(OBJDUMP_PRIVATE_OFILES)
-AC_SUBST(LIBCTF)
AC_DEFINE_UNQUOTED(TARGET, "${target}", [Configured target name.])