summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2005-03-22 00:49:18 +0000
committerZack Weinberg <zackw@panix.com>2005-03-22 00:49:18 +0000
commit479759c861f07d40b18c9673919991a95eb85f5b (patch)
tree2fd9cb0180ffee9f3a9e17dfb473841cdcd8c568 /configure.in
parent53107cc4a4a3e6919b390b958fabfca5a638e518 (diff)
top:
* Makefile.def: Remove libstdcxx_incdir, libsubdir, gxx_include_dir, gcc_version, and gcc_version_trigger from set of flags to pass. * Makefile.tpl: Remove definitions of above variables. (config.status): Remove dependency on $(gcc_version_trigger). * Makefile.in: Regenerate. * configure.in: Do not reference config/gcc-version.m4 nor config/gxx-include-dir.m4. Do not invoke TL_AC_GCC_VERSION nor TL_AC_GXX_INCLUDE_DIR. Do not set gcc_version_trigger. * configure: Regenerate. config: * gxx-include-dir.m4: In all substitutions, leave $(gcc_version) to be expanded by the Makefile.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 59d349cd8d..424346344c 100644
--- a/configure.in
+++ b/configure.in
@@ -19,8 +19,6 @@
### WARNING: this file contains embedded tabs. Do not run untabify on this file.
sinclude(config/acx.m4)
-sinclude(config/gcc-version.m4)
-sinclude(config/gxx-include-dir.m4)
AC_INIT(move-if-change)
AC_PREREQ(2.13)
@@ -101,22 +99,6 @@ topsrcdir=$srcpwd
extra_host_args=
-# Define the trigger file to make sure configure will re-run whenever
-# the gcc version number changes.
-TL_AC_GCC_VERSION([$topsrcdir])
-if test -f $gcc_version_trigger ; then
- case "$ac_configure_args" in
- *--with-gcc-version-trigger=$gcc_version_trigger* )
- ;;
- * )
- # Add to all subconfigure arguments: build, host, and target.
- ac_configure_args="$ac_configure_args --with-gcc-version-trigger=$gcc_version_trigger"
- ;;
- esac
-else
- gcc_version_trigger=
-fi
-
### To add a new directory to the tree, first choose whether it is a target
### or a host dependent tool. Then put it into the appropriate list
### (library or tools, host or target), doing a dependency sort.
@@ -1966,9 +1948,6 @@ fi
# Pass the appropriate --host, --build, and --cache-file arguments.
target_configargs="--cache-file=./config.cache --host=${target_alias} --build=${build_alias} ${target_configargs}"
-# provide a proper gxx_include_dir.
-TL_AC_GXX_INCLUDE_DIR
-
FLAGS_FOR_TARGET=
case " $target_configdirs " in
*" newlib "*)