summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2010-02-06 20:14:01 +0000
committerIan Lance Taylor <ian@airs.com>2010-02-06 20:14:01 +0000
commit9109c078e3f7ede78b1cd64efe05a55df993dc5a (patch)
tree0d9eb25cbb398d0f81b444682d8ebb5d62414072 /gold/configure.ac
parentcf846138aeaf3dceb0c339dd3e0ad7cc66140f81 (diff)
* configure.ac: Rewrite targetobjs duplicate removal code to use
only shell constructs. * configure: Rebuild.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 4bf223cb51..f184d4b29d 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -163,7 +163,14 @@ for targ in $target $canon_targets; do
done
# Remove any duplicates.
-targetobjs=`echo $targetobjs | tr ' ' '\n' | sort | uniq | tr '\n' ' '`
+to=""
+for t in $targetobjs; do
+ case " $to " in
+ *" $t "*) ;;
+ *) to="$to $t" ;;
+ esac
+done
+targetobjs=$to
if test -n "$targ_32_little"; then
AC_DEFINE(HAVE_TARGET_32_LITTLE, 1,