summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-03-02 14:51:42 +0000
committerIan Lance Taylor <ian@airs.com>2011-03-02 14:51:42 +0000
commitd0773f31b4d16d5c88df71944ec26273c59988ec (patch)
tree57f4f9a0a42930034d74dcb0313c28f05fd78704 /gold/configure.ac
parent4db71c0b79ff7e89a392f903f39251faa795d69c (diff)
* configure.ac: Add check for gnu_indirect_function support in
the toolchain building binutils. * configure: Rebuild.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 2c50d9741c..60243d0709 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -369,7 +369,7 @@ fi
AC_SUBST(RANDOM_SEED_CFLAGS)
dnl On GNU/Linux ifunc is supported by the dynamic linker in glibc
-dnl 2.11 or later.
+dnl 2.11 or later, and by binutils 2.20.1 or later.
AC_CACHE_CHECK([for glibc >= 2.11], [gold_cv_lib_glibc2_11],
[AC_COMPILE_IFELSE([
#include <features.h>
@@ -378,6 +378,7 @@ error
#elif __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 11)
error
#endif
+__asm__(".type foo, %gnu_indirect_function");
], [gold_cv_lib_glibc2_11=yes], [gold_cv_lib_glibc2_11=no])])
AM_CONDITIONAL(IFUNC, test "$gold_cv_lib_glibc2_11" = "yes")