aboutsummaryrefslogtreecommitdiff
path: root/libcxx/include/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolas Klauser <nikolasklauser@berlin.de>2022-08-02 22:40:13 -0700
committerTom Stellard <tstellar@redhat.com>2022-08-05 01:04:08 -0700
commit1ee16f1049e2f79f590d6982c6a23bb4cde44a89 (patch)
tree7e2f4395f3fc754bf1c477d18180c04641764d8e /libcxx/include/CMakeLists.txt
parent24186f723b91c8d05a269c05579aad3753bc0153 (diff)
[libc++][ranges] Implement `ranges::{prev, next}_permutation`.
Co-authored-by: Konstantin Varlamov <varconst@apple.com> Differential Revision: https://reviews.llvm.org/D129859 (cherry picked from commit 68264b649461206dc095e672eacf8a003e0b9e49)
Diffstat (limited to 'libcxx/include/CMakeLists.txt')
-rw-r--r--libcxx/include/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcxx/include/CMakeLists.txt b/libcxx/include/CMakeLists.txt
index 297e9029f3bf..e4da38dfb82b 100644
--- a/libcxx/include/CMakeLists.txt
+++ b/libcxx/include/CMakeLists.txt
@@ -113,6 +113,7 @@ set(files
__algorithm/ranges_mismatch.h
__algorithm/ranges_move.h
__algorithm/ranges_move_backward.h
+ __algorithm/ranges_next_permutation.h
__algorithm/ranges_none_of.h
__algorithm/ranges_nth_element.h
__algorithm/ranges_partial_sort.h
@@ -121,6 +122,7 @@ set(files
__algorithm/ranges_partition_copy.h
__algorithm/ranges_partition_point.h
__algorithm/ranges_pop_heap.h
+ __algorithm/ranges_prev_permutation.h
__algorithm/ranges_push_heap.h
__algorithm/ranges_remove.h
__algorithm/ranges_remove_copy.h