aboutsummaryrefslogtreecommitdiff
path: root/libcxx/include/CMakeLists.txt
diff options
context:
space:
mode:
authorLouis Dionne <ldionne.2@gmail.com>2022-07-25 13:43:47 -0400
committerTom Stellard <tstellar@redhat.com>2022-08-02 21:48:48 -0700
commit3a55353fc6f941394e6532b8ef5e59924e1ba899 (patch)
tree49214891860beebe97507cde2635e042c6f1ab04 /libcxx/include/CMakeLists.txt
parent62f1e6638158d8848777a29d9d142bb5481c7b67 (diff)
[libc++] Rename __libcpp_assertion_handler to __libcpp_verbose_abort
With the goal of reusing that handler to do other things besides handling assertions (such as terminating when an exception is thrown under -fno-exceptions), the name `__libcpp_assertion_handler` doesn't really make sense anymore. Furthermore, I didn't want to use the name `__libcpp_abort_handler`, since that would give the impression that the handler is called whenever `std::abort()` is called, which is not the case at all. Differential Revision: https://reviews.llvm.org/D130562 (cherry picked from commit 507125af3d0b953cb56bce2e5b8000249fe1ef53)
Diffstat (limited to 'libcxx/include/CMakeLists.txt')
-rw-r--r--libcxx/include/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libcxx/include/CMakeLists.txt b/libcxx/include/CMakeLists.txt
index 36eb70d39d76..1193f680c4fe 100644
--- a/libcxx/include/CMakeLists.txt
+++ b/libcxx/include/CMakeLists.txt
@@ -637,6 +637,7 @@ set(files
__utility/transaction.h
__utility/unreachable.h
__variant/monostate.h
+ __verbose_abort
algorithm
any
array