aboutsummaryrefslogtreecommitdiff
path: root/llvm/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorZi Xuan Wu <zixuan.wu@linux.alibaba.com>2022-02-15 15:26:39 +0800
committerZi Xuan Wu <zixuan.wu@linux.alibaba.com>2022-02-28 11:35:07 +0800
commit21bce9007ae818f95863dca928c1488d982e5383 (patch)
tree9d6322b27a6eddf9a840dfe1a23dc71d196f7279 /llvm/lib/Support/CMakeLists.txt
parent7f811ce12744db67e9d6450541c6bd313e06db59 (diff)
[Support] Add CSKY target parser and attributes parser
Construct LLVM Support module about CSKY target parser and attribute parser. It refers CSKY ABIv2 and implementation of GNU binutils and GCC. https://github.com/c-sky/csky-doc/blob/master/C-SKY_V2_CPU_Applications_Binary_Interface_Standards_Manual.pdf Now we only support CSKY 800 series cpus and newer cpus in the future undering CSKYv2 ABI specification. There are 11 archs including ck801, ck802, ck803, ck803s, ck804, ck805, ck807, ck810, ck810v, ck860, ck860v. Every arch has base extensions, the cpus of that arch family have more extended extensions than base extensions. We need specify extended extensions for every cpu. Every extension has its enum value, name and related llvm feature string with +/-. Every enum value represents a bit of uint64_t integer. Differential Revision: https://reviews.llvm.org/D119917
Diffstat (limited to 'llvm/lib/Support/CMakeLists.txt')
-rw-r--r--llvm/lib/Support/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt
index 4d9099554192..b9afc33d89d2 100644
--- a/llvm/lib/Support/CMakeLists.txt
+++ b/llvm/lib/Support/CMakeLists.txt
@@ -134,6 +134,9 @@ add_llvm_component_library(LLVMSupport
ConvertUTF.cpp
ConvertUTFWrapper.cpp
CrashRecoveryContext.cpp
+ CSKYAttributes.cpp
+ CSKYAttributeParser.cpp
+ CSKYTargetParser.cpp
DataExtractor.cpp
Debug.cpp
DebugCounter.cpp