aboutsummaryrefslogtreecommitdiff
path: root/llvm/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Ganea <alexandre.ganea@legionlabs.com>2022-04-11 17:22:53 -0400
committerAlexandre Ganea <alexandre.ganea@legionlabs.com>2022-04-15 15:19:38 -0400
commit64969446bc27a955b77a3a4e9ee22af7043bcba1 (patch)
treed2b27c676468a01d93debb221415325407b0b354 /llvm/lib/Support/CMakeLists.txt
parent721651be246e26efd767c3ec55c8f06c7b5a9a3d (diff)
[Support][cmake] Fix snmalloc integration. NFC.
When using LLVM_INTEGRATED_CRT_ALLOC, fix compiling with the latest snmalloc at ToT (https://github.com/microsoft/snmalloc).
Diffstat (limited to 'llvm/lib/Support/CMakeLists.txt')
-rw-r--r--llvm/lib/Support/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt
index 7cbff3dddbcd..4d9956ba8336 100644
--- a/llvm/lib/Support/CMakeLists.txt
+++ b/llvm/lib/Support/CMakeLists.txt
@@ -90,7 +90,7 @@ if(LLVM_INTEGRATED_CRT_ALLOC)
add_definitions(-DENABLE_OVERRIDE -DENABLE_PRELOAD)
set(ALLOCATOR_FILES "${LLVM_INTEGRATED_CRT_ALLOC}/rpmalloc/rpmalloc.c")
elseif(LLVM_INTEGRATED_CRT_ALLOC MATCHES "snmalloc$")
- set(ALLOCATOR_FILES "${LLVM_INTEGRATED_CRT_ALLOC}/src/override/malloc.cc" "${LLVM_INTEGRATED_CRT_ALLOC}/src/override/new.cc")
+ set(ALLOCATOR_FILES "${LLVM_INTEGRATED_CRT_ALLOC}/src/snmalloc/override/new.cc")
set(system_libs ${system_libs} "mincore.lib" "-INCLUDE:malloc")
elseif(LLVM_INTEGRATED_CRT_ALLOC MATCHES "mimalloc$")
set(MIMALLOC_LIB "${LLVM_INTEGRATED_CRT_ALLOC}/out/msvc-x64/Release/mimalloc-static.lib")