aboutsummaryrefslogtreecommitdiff
path: root/llvm/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorserge-sans-paille <sguelton@redhat.com>2020-10-09 18:41:21 +0200
committerserge-sans-paille <sguelton@redhat.com>2020-11-13 10:35:24 +0100
commit9218ff50f93085d0a16a974db28ca8f14bc66f64 (patch)
tree00618a75171e9b483b20315faefaec17641200e4 /llvm/lib/Support/CMakeLists.txt
parentb498303066a63a203d24f739b2d2e0e56dca70d1 (diff)
llvmbuildectomy - replace llvm-build by plain cmake
No longer rely on an external tool to build the llvm component layout. Instead, leverage the existing `add_llvm_componentlibrary` cmake function and introduce `add_llvm_component_group` to accurately describe component behavior. These function store extra properties in the created targets. These properties are processed once all components are defined to resolve library dependencies and produce the header expected by llvm-config. Differential Revision: https://reviews.llvm.org/D90848
Diffstat (limited to 'llvm/lib/Support/CMakeLists.txt')
-rw-r--r--llvm/lib/Support/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt
index 24b0fc715cd9..337d07d0a9dc 100644
--- a/llvm/lib/Support/CMakeLists.txt
+++ b/llvm/lib/Support/CMakeLists.txt
@@ -222,7 +222,12 @@ add_llvm_component_library(LLVMSupport
${LLVM_MAIN_INCLUDE_DIR}/llvm/ADT
${LLVM_MAIN_INCLUDE_DIR}/llvm/Support
${Backtrace_INCLUDE_DIRS}
- LINK_LIBS ${system_libs} ${imported_libs} ${delayload_flags}
+
+ LINK_LIBS
+ ${system_libs} ${imported_libs} ${delayload_flags}
+
+ LINK_COMPONENTS
+ Demangle
)
set(llvm_system_libs ${system_libs})