aboutsummaryrefslogtreecommitdiff
path: root/llvm/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorCole Kissane <cole.kissane@gmail.com>2022-07-13 19:06:26 -0700
committerCole Kissane <cole.kissane@gmail.com>2022-07-13 19:06:27 -0700
commitcef07169ec9f46fd25291a3218cf12bef324ea0c (patch)
tree2286d3caed36227224723314bca1392c4da60745 /llvm/lib/Support/CMakeLists.txt
parentee37ae91b6ee5938b2460cd12c547449bd946b1e (diff)
[llvm] add zstd to `llvm::compression` namespace
- add `FindZSTD.cmake` - add zstd to `llvm::compression` namespace - add a CMake option `LLVM_ENABLE_ZSTD` with behavior mirroring that of `LLVM_ENABLE_ZLIB` - add tests for zstd to `llvm/unittests/Support/CompressionTest.cpp` Reviewed By: leonardchan, MaskRay Differential Revision: https://reviews.llvm.org/D128465
Diffstat (limited to 'llvm/lib/Support/CMakeLists.txt')
-rw-r--r--llvm/lib/Support/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt
index e1045e459d70..52b95c5377d3 100644
--- a/llvm/lib/Support/CMakeLists.txt
+++ b/llvm/lib/Support/CMakeLists.txt
@@ -25,6 +25,10 @@ if(LLVM_ENABLE_ZLIB)
set(imported_libs ZLIB::ZLIB)
endif()
+if(LLVM_ENABLE_ZSTD)
+ list(APPEND imported_libs zstd)
+endif()
+
if( MSVC OR MINGW )
# libuuid required for FOLDERID_Profile usage in lib/Support/Windows/Path.inc.
# advapi32 required for CryptAcquireContextW in lib/Support/Windows/Path.inc.