aboutsummaryrefslogtreecommitdiff
path: root/gotools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gotools/Makefile.am')
-rw-r--r--gotools/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gotools/Makefile.am b/gotools/Makefile.am
index ad0ad24e206..2ade1d7f019 100644
--- a/gotools/Makefile.am
+++ b/gotools/Makefile.am
@@ -100,8 +100,9 @@ MOSTLYCLEANFILES = \
*.sent
mostlyclean-local:
- -chmod -R u+w check-go-dir
- rm -rf check-go-dir check-runtime-dir cgo-test-dir carchive-test-dir
+ if test -d check-go-dir; then chmod -R u+w check-go-dir; fi
+ rm -rf check-go-dir check-runtime-dir cgo-test-dir carchive-test-dir \
+ check-vet-dir gocache-test
if NATIVE