aboutsummaryrefslogtreecommitdiff
path: root/debian/rules.d/0-common-vars.mk
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2011-06-02 12:44:57 -0600
committerJohn Rigby <john.rigby@linaro.org>2011-08-21 23:21:17 -0600
commitc588ff5a379da4a2dc00510f8b7bb5019e56b307 (patch)
treeed14033f402328bfe43c390ecb963eed60cdb945 /debian/rules.d/0-common-vars.mk
parent7ffeb56f5d171f00b62c1d8a58dc9d2bd3b2cb46 (diff)
LINARO: add flavour splitting script and changes to use it
Signed-off-by: John Rigby <john.rigby@linaro.org>
Diffstat (limited to 'debian/rules.d/0-common-vars.mk')
-rw-r--r--debian/rules.d/0-common-vars.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 0194db594a1..23ff1bfe0ea 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -2,6 +2,9 @@
# The source package name will be the first token from $(DEBIAN)/changelog
#
src_pkg_name=$(shell sed -n '1s/^\(.*\) (.*).*$$/\1/p' $(DEBIAN)/changelog)
+# Allow for overriding common_src_pkg_name when we have perflavour source packages
+-include $(DEBIAN)/rules.d/vars.mk
+common_src_pkg_name?=src_pkg_name
# Get some version info
series := oneiric
@@ -142,7 +145,7 @@ do_doc_package_content=true
ifeq ($(full_build),false)
do_doc_package_content=false
endif
-doc_pkg_name=$(src_pkg_name)-doc
+doc_pkg_name=$(common_src_pkg_name)-doc
#
# Similarly with the linux-source package, you need not build it as a developer. Its
@@ -169,8 +172,8 @@ do_tools?=true
else
do_tools?=false
endif
-tools_pkg_name=$(src_pkg_name)-tools-$(abi_release)
-tools_common_pkg_name=$(src_pkg_name)-tools-common
+tools_pkg_name=$(common_src_pkg_name)-tools-$(abi_release)
+tools_common_pkg_name=$(common_src_pkg_name)-tools-common
# The general flavour specific image package.
do_flavour_image_package=true