aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndy Whitcroft <apw@canonical.com>2011-05-31 10:42:49 +0100
committerJohn Rigby <john.rigby@linaro.org>2011-08-21 21:54:15 -0600
commit29b85627f49caf21166ec713e6d713063dc2d800 (patch)
tree4efa3ae58de06a69870d5b5b090c56416d0c38c8 /debian
parentde73c5a7f6474aebaa89af585397256b821d5d1a (diff)
UBUNTU: use the kernels idea of its version for version_signature
Signed-off-by: Andy Whitcroft <apw@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/0-common-vars.mk2
-rw-r--r--debian/rules.d/2-binary-arch.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 0e8e57114a9..13602c4dbf1 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -51,7 +51,7 @@ ubuntu_log_opts += --print-shas
endif
# Get the kernels own extra version to be added to the release signature.
-extraversion=$(shell awk '/EXTRAVERSION =/ { print $$3 }' <Makefile)
+raw_kernelversion=$(shell make kernelversion)
#
# full_build -- are we doing a full buildd style build
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 62c1fae51b4..c1515423fbc 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -21,7 +21,7 @@ $(stampdir)/stamp-prepare-tree-%: $(commonconfdir)/config.common.$(family) $(arc
touch $(builddir)/build-$*/ubuntu-build
[ "$(do_full_source)" != 'true' ] && true || \
rsync -a --exclude debian --exclude debian.master --exclude $(DEBIAN) * $(builddir)/build-$*
- cat $^ | sed -e 's/.*CONFIG_VERSION_SIGNATURE.*/CONFIG_VERSION_SIGNATURE="Ubuntu $(release)-$(revision)-$* $(release)$(extraversion)"/' > $(builddir)/build-$*/.config
+ cat $^ | sed -e 's/.*CONFIG_VERSION_SIGNATURE.*/CONFIG_VERSION_SIGNATURE="Ubuntu $(release)-$(revision)-$* $(raw_kernelversion)"/' > $(builddir)/build-$*/.config
find $(builddir)/build-$* -name "*.ko" | xargs rm -f
$(build_cd) $(kmake) $(build_O) silentoldconfig prepare scripts
touch $@