aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndy Whitcroft <apw@canonical.com>2011-05-31 10:28:05 +0100
committerJohn Rigby <john.rigby@linaro.org>2011-08-21 21:54:14 -0600
commitde73c5a7f6474aebaa89af585397256b821d5d1a (patch)
tree608220ed4d84a8ffabb3793f3ea867804d962491 /debian
parenta3955d53bcd8e79527566549917a89c02a34b88d (diff)
UBUNTU: use the packaging version in the kernel
Signed-off-by: Andy Whitcroft <apw@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/0-common-vars.mk9
-rw-r--r--debian/rules.d/1-maintainer.mk3
-rw-r--r--debian/rules.d/2-binary-arch.mk4
3 files changed, 4 insertions, 12 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 05a6ad74b91..0e8e57114a9 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -91,11 +91,6 @@ libc_dev_version := -v$(release)-$(shell expr "$(abinum)" + 1000).$(raw_uploadnu
endif
endif
-# We force the sublevel to be exactly what we want. The actual source may
-# be an in development git tree. We want to force it here instead of
-# committing changes to the top level Makefile
-SUBLEVEL := $(shell echo $(release) | awk -F. '{print $$3}')
-
DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -216,8 +211,8 @@ conc_level = -j$(CONCURRENCY_LEVEL)
# target_flavour is filled in for each step
kmake = make ARCH=$(build_arch) \
CROSS_COMPILE=$(CROSS_COMPILE) \
- EXTRAVERSION=-$(abinum)-$(target_flavour) \
- CONFIG_DEBUG_SECTION_MISMATCH=y SUBLEVEL=$(SUBLEVEL) \
+ KERNELVERSION=$(abi_release)-$(target_flavour) \
+ CONFIG_DEBUG_SECTION_MISMATCH=y \
KBUILD_BUILD_VERSION="$(uploadnum)" \
LOCALVERSION= localver-extra=
ifneq ($(LOCAL_ENV_CC),)
diff --git a/debian/rules.d/1-maintainer.mk b/debian/rules.d/1-maintainer.mk
index 2360dcad13d..517c604e112 100644
--- a/debian/rules.d/1-maintainer.mk
+++ b/debian/rules.d/1-maintainer.mk
@@ -65,9 +65,6 @@ printenv:
@echo "skipmodule = $(skipmodule)"
@echo "skipdbg = $(skipdbg)"
@echo "ubuntu_log_opts = $(ubuntu_log_opts)"
-ifneq ($(SUBLEVEL),)
- @echo "SUBLEVEL = $(SUBLEVEL)"
-endif
@echo "CONCURRENCY_LEVEL = $(CONCURRENCY_LEVEL)"
@echo "bin package name = $(bin_pkg_name)"
@echo "hdr package name = $(hdrs_pkg_name)"
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index cf112cde34c..62c1fae51b4 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -221,8 +221,8 @@ endif
headers_tmp := $(CURDIR)/debian/tmp-headers
headers_dir := $(CURDIR)/debian/linux-libc-dev
-hmake := $(MAKE) -C $(CURDIR) O=$(headers_tmp) SUBLEVEL=$(SUBLEVEL) \
- EXTRAVERSION=-$(abinum) INSTALL_HDR_PATH=$(headers_tmp)/install \
+hmake := $(MAKE) -C $(CURDIR) O=$(headers_tmp) \
+ KERNELVERSION=$(abi_release) INSTALL_HDR_PATH=$(headers_tmp)/install \
SHELL="$(SHELL)" ARCH=$(header_arch)
install-arch-headers: