aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/rules.d/0-common-vars.mk9
-rw-r--r--debian/rules.d/1-maintainer.mk1
3 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 92ec033af3e..0d87e2ccd93 100755
--- a/debian/rules
+++ b/debian/rules
@@ -91,16 +91,18 @@ $(DEBIAN)/control.stub: $(DEBIAN)/d-i/kernel-versions.in \
new=`echo $$i | sed 's/\.in$$//'`; \
cat $$i | sed -e 's/PKGVER/$(release)/g' \
-e 's/ABINUM/$(abinum)/g' \
+ -e 's/COMMONSRCPKGNAME/$(common_src_pkg_name)/g' \
-e 's/SRCPKGNAME/$(src_pkg_name)/g' \
> $$new; \
done
flavours="$(wildcard $(DEBIAN)/control.d/vars.* $(DEBIAN)/sub-flavours/*.vars)";\
for i in $$flavours; do \
- $(SHELL) $(DROOT)/scripts/control-create $$i | \
+ $(SHELL) $(DROOT)/scripts/control-create $$i | \
sed -e 's/PKGVER/$(release)/g' \
-e 's/ABINUM/$(abinum)/g' \
+ -e 's/COMMONSRCPKGNAME/$(common_src_pkg_name)/g' \
-e 's/SRCPKGNAME/$(src_pkg_name)/g' \
- >> $(DEBIAN)/control.stub; \
+ >> $(DEBIAN)/control.stub; \
done
cp $(DEBIAN)/control.stub $(DEBIAN)/control
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 0194db594a1..23ff1bfe0ea 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -2,6 +2,9 @@
# The source package name will be the first token from $(DEBIAN)/changelog
#
src_pkg_name=$(shell sed -n '1s/^\(.*\) (.*).*$$/\1/p' $(DEBIAN)/changelog)
+# Allow for overriding common_src_pkg_name when we have perflavour source packages
+-include $(DEBIAN)/rules.d/vars.mk
+common_src_pkg_name?=src_pkg_name
# Get some version info
series := oneiric
@@ -142,7 +145,7 @@ do_doc_package_content=true
ifeq ($(full_build),false)
do_doc_package_content=false
endif
-doc_pkg_name=$(src_pkg_name)-doc
+doc_pkg_name=$(common_src_pkg_name)-doc
#
# Similarly with the linux-source package, you need not build it as a developer. Its
@@ -169,8 +172,8 @@ do_tools?=true
else
do_tools?=false
endif
-tools_pkg_name=$(src_pkg_name)-tools-$(abi_release)
-tools_common_pkg_name=$(src_pkg_name)-tools-common
+tools_pkg_name=$(common_src_pkg_name)-tools-$(abi_release)
+tools_common_pkg_name=$(common_src_pkg_name)-tools-common
# The general flavour specific image package.
do_flavour_image_package=true
diff --git a/debian/rules.d/1-maintainer.mk b/debian/rules.d/1-maintainer.mk
index 6ed6c147618..2ecac0b7c51 100644
--- a/debian/rules.d/1-maintainer.mk
+++ b/debian/rules.d/1-maintainer.mk
@@ -52,6 +52,7 @@ updateportsconfigs defaultportsconfigs editportsconfigs genportsconfigs askconfi
printenv:
dh_testdir
@echo "src package name = $(src_pkg_name)"
+ @echo "src package name no flavour = $(common_src_pkg_name)"
@echo "release = $(release)"
@echo "revisions = $(revisions)"
@echo "revision = $(revision)"