aboutsummaryrefslogtreecommitdiff
path: root/tools/gator/debian/rules
diff options
context:
space:
mode:
authorAndrey Konovalov <andrey.konovalov@linaro.org>2012-08-13 20:16:08 +0400
committerAndrey Konovalov <andrey.konovalov@linaro.org>2012-08-13 20:16:08 +0400
commitdc45bcf8f4bf7830ccfcef68789e337178923059 (patch)
tree5a08685473f2105df293d3d60fa0cca417fbbbfb /tools/gator/debian/rules
parent51c87f97300f24bad49100b4a88551195daa0c30 (diff)
parent36cca01e58142336ffddc1cd268a374da7907512 (diff)
Merge branch 'tracking-gator' into merge-linux-linaro-core-trackingllct-20120813.0
Diffstat (limited to 'tools/gator/debian/rules')
-rwxr-xr-xtools/gator/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/gator/debian/rules b/tools/gator/debian/rules
new file mode 100755
index 000000000000..c747748ff83c
--- /dev/null
+++ b/tools/gator/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ CROSS_COMPILE ?= $(DEB_HOST_GNU_TYPE)-
+endif
+
+export CROSS_COMPILE
+
+export DH_OPTIONS
+
+%:
+ dh $@