aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-02-28 11:26:56 +0200
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2017-04-14 15:17:12 +0200
commitcb92b4f219aaea8f7b2224c6c3f74b22557357ca (patch)
tree85d1c054913006f46bde50d35ce2330d96731dff
parent59a3670f1d034cd8a60fcbe12620ac0bff206a28 (diff)
mesa: Upgrade 13.0.4 -> 17.0.2
Backported and squashed the following patches from upstream: be95558834 mesa: Upgrade 13.0.4 -> 17.0.0 465a6b49b6 mesa: Upgrade 17.0.0 -> 17.0.1 33c8918d41 mesa: Enable vulkan driver for intel df53927b9c mesa: Contain configure search for llvm 7df24c8499 mesa-gl: Drop MESA_CRYPTO from PACKAGECONFIG 7559db30e1 mesa: Update to 17.0.2 Tested on DB410c with freedreno. * gtkperf -a ** 10.30ms (no openbox) ** 11.40ms (with openbox) * glmark ** 121 (no openbox) ** 122 (with openbox) Change-Id: I980ac58bd68721ee485f69b05f7a5314fff928ab Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--openembedded-layer/recipes-graphics/mesa/mesa-gl_17.0.2.bb (renamed from openembedded-layer/recipes-graphics/mesa/mesa-gl_13.0.4.bb)2
-rw-r--r--openembedded-layer/recipes-graphics/mesa/mesa.inc22
-rw-r--r--openembedded-layer/recipes-graphics/mesa/mesa_17.0.2.bb (renamed from openembedded-layer/recipes-graphics/mesa/mesa_13.0.4.bb)6
3 files changed, 13 insertions, 17 deletions
diff --git a/openembedded-layer/recipes-graphics/mesa/mesa-gl_13.0.4.bb b/openembedded-layer/recipes-graphics/mesa/mesa-gl_17.0.2.bb
index f06a3e9..fc2bca9 100644
--- a/openembedded-layer/recipes-graphics/mesa/mesa-gl_13.0.4.bb
+++ b/openembedded-layer/recipes-graphics/mesa/mesa-gl_17.0.2.bb
@@ -8,6 +8,6 @@ PROVIDES = "virtual/libgl virtual/mesa"
S = "${WORKDIR}/mesa-${PV}"
-PACKAGECONFIG ??= "dri ${MESA_CRYPTO} ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+PACKAGECONFIG ??= "dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
EXCLUDE_FROM_WORLD = "1"
diff --git a/openembedded-layer/recipes-graphics/mesa/mesa.inc b/openembedded-layer/recipes-graphics/mesa/mesa.inc
index 1f9fbca..954688c 100644
--- a/openembedded-layer/recipes-graphics/mesa/mesa.inc
+++ b/openembedded-layer/recipes-graphics/mesa/mesa.inc
@@ -22,9 +22,9 @@ inherit autotools pkgconfig pythonnative gettext distro_features_check
REQUIRED_DISTRO_FEATURES = "opengl"
-EXTRA_OECONF = "--enable-shared-glapi"
+EXTRA_OECONF = "--enable-shared-glapi --with-llvm-prefix=${STAGING_BINDIR_NATIVE}"
-PACKAGECONFIG ??= "gbm egl gles dri ${MESA_CRYPTO} \
+PACKAGECONFIG ??= "gbm egl gles dri \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}\
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}\
"
@@ -42,6 +42,10 @@ DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau,i965,i915"
PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm"
PACKAGECONFIG[dri3] = "--enable-dri3, --disable-dri3, dri3proto presentproto libxshmfence"
+# Vulkan drivers need dri3 enabled
+# radeon could be enabled as well but requires gallium-llvm with llvm >= 3.9
+PACKAGECONFIG[vulkan] = "--with-vulkan-drivers=intel, --without-vulkan-drivers"
+
PACKAGECONFIG[gles] = "--enable-gles1 --enable-gles2, --disable-gles1 --disable-gles2"
EGL_PLATFORMS = "drm"
@@ -67,12 +71,6 @@ PACKAGECONFIG[xa] = "--enable-xa, --disable-xa"
OSMESA = "${@bb.utils.contains('PACKAGECONFIG', 'gallium', 'gallium-osmesa', 'osmesa', d)}"
PACKAGECONFIG[osmesa] = "--enable-${OSMESA},--disable-${OSMESA}"
-# Mesa requires one of the following crypto implementation, pick one of them
-MESA_CRYPTO ??= "openssl"
-PACKAGECONFIG[openssl] = "--with-sha1=libcrypto,,openssl"
-PACKAGECONFIG[nettle] = "--with-sha1=libnettle,,nettle"
-PACKAGECONFIG[gcrypt] = "--with-sha1=libgcrypt,,libgcrypt"
-
# llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2)
FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer"
@@ -94,9 +92,8 @@ PACKAGES =+ "libegl-mesa libegl-mesa-dev \
libgles2-mesa libgles2-mesa-dev \
libgles3-mesa libgles3-mesa-dev \
libwayland-egl libwayland-egl-dev \
- libxvmcsoftpipe libxvmcsoftpipe-dev \
libxatracker libxatracker-dev \
- mesa-megadriver \
+ mesa-megadriver mesa-vulkan-drivers \
"
do_install_append () {
@@ -170,6 +167,7 @@ PACKAGES_DYNAMIC += "^mesa-driver-.*"
FILES_${PN} += "${sysconfdir}/drirc"
FILES_mesa-megadriver = "${libdir}/dri/*"
+FILES_mesa-vulkan-drivers = "${libdir}/libvulkan_*.so ${datadir}/vulkan"
FILES_libegl-mesa = "${libdir}/libEGL.so.*"
FILES_libgbm = "${libdir}/libgbm.so.*"
FILES_libgles1-mesa = "${libdir}/libGLESv1*.so.*"
@@ -178,10 +176,9 @@ FILES_libgl-mesa = "${libdir}/libGL.so.*"
FILES_libglapi = "${libdir}/libglapi.so.*"
FILES_libosmesa = "${libdir}/libOSMesa.so.*"
FILES_libwayland-egl = "${libdir}/libwayland-egl.so.*"
-FILES_libxvmcsoftpipe = "${libdir}/libXvMCsoftpipe.so.*"
FILES_libxatracker = "${libdir}/libxatracker.so.*"
-FILES_${PN}-dev = "${libdir}/pkgconfig/dri.pc"
+FILES_${PN}-dev = "${libdir}/pkgconfig/dri.pc ${includedir}/vulkan"
FILES_libegl-mesa-dev = "${libdir}/libEGL.* ${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc"
FILES_libgbm-dev = "${libdir}/libgbm.* ${libdir}/pkgconfig/gbm.pc ${includedir}/gbm.h"
FILES_libgl-mesa-dev = "${libdir}/libGL.* ${includedir}/GL ${libdir}/pkgconfig/gl.pc"
@@ -191,7 +188,6 @@ FILES_libgles2-mesa-dev = "${libdir}/libGLESv2.* ${includedir}/GLES2 ${libdir}/p
FILES_libgles3-mesa-dev = "${includedir}/GLES3"
FILES_libosmesa-dev = "${libdir}/libOSMesa.* ${includedir}/GL/osmesa.h ${libdir}/pkgconfig/osmesa.pc"
FILES_libwayland-egl-dev = "${libdir}/pkgconfig/wayland-egl.pc ${libdir}/libwayland-egl.*"
-FILES_libxvmcsoftpipe-dev = "${libdir}/libXvMCsoftpipe.so ${libdir}/libXvMCsoftpipe.la"
FILES_libxatracker-dev = "${libdir}/libxatracker.so ${libdir}/libxatracker.la \
${includedir}/xa_tracker.h ${includedir}/xa_composite.h ${includedir}/xa_context.h \
${libdir}/pkgconfig/xatracker.pc"
diff --git a/openembedded-layer/recipes-graphics/mesa/mesa_13.0.4.bb b/openembedded-layer/recipes-graphics/mesa/mesa_17.0.2.bb
index 1416c9f..2689e8f 100644
--- a/openembedded-layer/recipes-graphics/mesa/mesa_13.0.4.bb
+++ b/openembedded-layer/recipes-graphics/mesa/mesa_17.0.2.bb
@@ -1,13 +1,13 @@
require ${BPN}.inc
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
file://replace_glibc_check_with_linux.patch \
file://disable-asm-on-non-gcc.patch \
file://0001-Use-wayland-scanner-in-the-path.patch \
"
-SRC_URI[md5sum] = "d088a921e935218833a8071cb672a574"
-SRC_URI[sha256sum] = "a95d7ce8f7bd5f88585e4be3144a341236d8c0fc91f6feaec59bb8ba3120e726"
+SRC_URI[md5sum] = "8f808e92b893d412fbd6510e1d16f5c5"
+SRC_URI[sha256sum] = "f8f191f909e01e65de38d5bdea5fb057f21649a3aed20948be02348e77a689d4"
#because we cannot rely on the fact that all apps will use pkgconfig,
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER