summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAurelien Jarno <aurelien@aurel32.net>2020-02-16 15:56:58 +0100
committerAurelien Jarno <aurelien@aurel32.net>2020-02-16 15:56:58 +0100
commitd4fb6e5cbe20da930f947fe26491878c8177d36f (patch)
tree320aa3270772b43fddda68201eedc71aa9fd8f91
parent21a8c5ee6ef605bf53aba25cd8f57b7269e728b7 (diff)
parentca20bcb2435fe625ae45748b884916fd9ef78115 (diff)
Merge branch 'glibc-2.30' into glibc-2.31
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/any/submitted-stt-gnu-ifunc-detection.patch23
-rw-r--r--debian/patches/hurd-i386/git-pthread_self.diff31
-rw-r--r--debian/patches/series1
4 files changed, 52 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 75e2725f..b6acabaf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -72,10 +72,17 @@ glibc (2.30-0experimental3) UNRELEASED; urgency=medium
libpthread link.
* debian/patches/hurd-i386/git-register-atfork.diff: Fix linking with static
libpthread.
+ * debian/patches/hurd-i386/git-pthread_self.diff: New patch to improve
+ libpthread performance.
[ Aurelien Jarno ]
* debian/patches/any/local-revert-24323.diff: drop, obsolete.
* debian/control.in/libc: add a Breaks: against wcc (<< 0.0.2+dfsg-3).
+ * debian/patches/any/submitted-stt-gnu-ifunc-detection.patch: update to
+ version 2 of the patch to fix the wrong detection on sparc.
+ * debian/patches/git-updates.diff: update from upstream stable branch:
+ - Fix argument passing for inlined syscalls on mips* and riscv64.
+ Closes: #951237.
-- Samuel Thibault <sthibault@debian.org> Sat, 08 Feb 2020 03:08:56 +0100
diff --git a/debian/patches/any/submitted-stt-gnu-ifunc-detection.patch b/debian/patches/any/submitted-stt-gnu-ifunc-detection.patch
index b8480899..541b902f 100644
--- a/debian/patches/any/submitted-stt-gnu-ifunc-detection.patch
+++ b/debian/patches/any/submitted-stt-gnu-ifunc-detection.patch
@@ -1,12 +1,15 @@
-commit 8f923e75945a6e829d5640ac412b5e9555e5ef9c
-Author: Fangrui Song <maskray@google.com>
-Date: Tue Feb 4 22:09:22 2020 -0800
+From 624b3a0c9e4f2f421227bb3f331723dfe807f157 Mon Sep 17 00:00:00 2001
+From: Fangrui Song <maskray@google.com>
+Date: Tue, 4 Feb 2020 21:55:44 -0800
+Subject: [PATCH] Improve IFUNC check [BZ #25506]
- Improve IFUNC check
-
- GNU ld's RISCV port does not support IFUNC. ld -no-pie produces no
- relocation and the test passed incorrectly. Be more rigid by testing
- IRELATIVE explicitly.
+GNU ld does not support IFUNC but does not produces a relocation.
+The test passed incorrectly. Be more rigid by testing IRELATIVE
+explicitly.
+---
+ configure | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
--- a/configure
+++ b/configure
@@ -15,7 +18,7 @@ Date: Tue Feb 4 22:09:22 2020 -0800
# Do a link to see if the backend supports IFUNC relocs.
$READELF -r conftest 1>&5
- LC_ALL=C $READELF -r conftest | grep 'no relocations' >/dev/null || {
-+ LC_ALL=C $READELF -Wr conftest | grep -q IRELATIVE && {
++ LC_ALL=C $READELF -Wr conftest | grep -q 'IRELATIVE\|R_SPARC_JMP_IREL' && {
libc_cv_ld_gnu_indirect_function=yes
}
fi
@@ -26,7 +29,7 @@ Date: Tue Feb 4 22:09:22 2020 -0800
# Do a link to see if the backend supports IFUNC relocs.
$READELF -r conftest 1>&AS_MESSAGE_LOG_FD
- LC_ALL=C $READELF -r conftest | grep 'no relocations' >/dev/null || {
-+ LC_ALL=C $READELF -Wr conftest | grep -q IRELATIVE && {
++ LC_ALL=C $READELF -Wr conftest | grep -q 'IRELATIVE\|R_SPARC_JMP_IREL' && {
libc_cv_ld_gnu_indirect_function=yes
}
fi
diff --git a/debian/patches/hurd-i386/git-pthread_self.diff b/debian/patches/hurd-i386/git-pthread_self.diff
new file mode 100644
index 00000000..709c9759
--- /dev/null
+++ b/debian/patches/hurd-i386/git-pthread_self.diff
@@ -0,0 +1,31 @@
+commit ca843defbcbd2dc95b9342189e5dc430e9bcb743
+Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Sat Feb 15 14:31:50 2020 +0000
+
+ htl: Only check pthread_self coherency when DEBUG is set
+
+ htl has been widely tested for a long time now with this coherency
+ checked successfully.
+
+diff --git a/sysdeps/mach/hurd/htl/pt-sysdep.h b/sysdeps/mach/hurd/htl/pt-sysdep.h
+index c837415a9a..484d024bb0 100644
+--- a/sysdeps/mach/hurd/htl/pt-sysdep.h
++++ b/sysdeps/mach/hurd/htl/pt-sysdep.h
+@@ -32,6 +32,7 @@
+ mach_msg_header_t wakeupmsg;
+
+ extern __thread struct __pthread *___pthread_self;
++#ifdef DEBUG
+ #define _pthread_self() \
+ ({ \
+ struct __pthread *thread; \
+@@ -46,6 +47,9 @@ extern __thread struct __pthread *___pthread_self;
+ ok; })); \
+ thread; \
+ })
++#else
++#define _pthread_self() ___pthread_self
++#endif
+
+ extern inline void
+ __attribute__ ((__always_inline__))
diff --git a/debian/patches/series b/debian/patches/series
index ee83106c..89637cc2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -63,6 +63,7 @@ hurd-i386/git-spin_lock.diff
hurd-i386/git-barrier-1.diff
hurd-i386/git-sem-intr.diff
hurd-i386/git-register-atfork.diff
+hurd-i386/git-pthread_self.diff
i386/local-biarch.diff
i386/unsubmitted-quiet-ldconfig.diff