summaryrefslogtreecommitdiff
path: root/debian/rules.d
diff options
context:
space:
mode:
authorAurelien Jarno <aurelien@aurel32.net>2017-12-09 10:27:10 +0100
committerAurelien Jarno <aurelien@aurel32.net>2017-12-09 10:27:10 +0100
commit0f960b389dd8ad8aca62d625087e8ced72c4a9ac (patch)
treedb0bfd3e8e9bcdaf6184f94f00cea082b176a908 /debian/rules.d
parentee99e1b2f1112cec3799f9c9360484bef45be089 (diff)
debian/rules, debian/rules.d/debhelper.mk: revert the logic to build libc6-dbg. Only fill it with files from the main libc and optimized flavours. Other debugging symbols are available in the dbgsym packages. Closes: #520680.
Diffstat (limited to 'debian/rules.d')
-rw-r--r--debian/rules.d/debhelper.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules.d/debhelper.mk b/debian/rules.d/debhelper.mk
index b55ed05d..840e059c 100644
--- a/debian/rules.d/debhelper.mk
+++ b/debian/rules.d/debhelper.mk
@@ -43,7 +43,7 @@ ifeq ($(filter nostrip,$(DEB_BUILD_OPTIONS)),)
# table in libc6-dbg but basic thread debugging should
# work even without that package installed.
if test "$(NOSTRIP_$(curpass))" != 1; then \
- if test "$(NODEBUG_$(curpass))" != 1; then \
+ if test "$(DEBUG_$(curpass))" = 1; then \
dh_strip -p$(curpass) -Xlibpthread $(DH_STRIP_DEBUG_PACKAGE); \
for f in $$(find debian/$(curpass) -name libpthread-\*.so) ; do \
dbgfile=$$(LC_ALL=C readelf -n $$f | sed -e '/Build ID:/!d' \