aboutsummaryrefslogtreecommitdiff
path: root/product/juno/module/juno_rom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'product/juno/module/juno_rom/CMakeLists.txt')
-rw-r--r--product/juno/module/juno_rom/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/product/juno/module/juno_rom/CMakeLists.txt b/product/juno/module/juno_rom/CMakeLists.txt
index 4950d95850e4..64eef8fd0b93 100644
--- a/product/juno/module/juno_rom/CMakeLists.txt
+++ b/product/juno/module/juno_rom/CMakeLists.txt
@@ -15,6 +15,14 @@ target_sources(
"${CMAKE_CURRENT_SOURCE_DIR}/src/juno_debug_rom.c"
"${CMAKE_CURRENT_SOURCE_DIR}/src/mod_juno_rom.c")
+if(SCP_MODULE IN_LIST SCP_DT_CONFIG_MODULES_ALL)
+ target_sources(${SCP_MODULE_TARGET}
+ PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/src/config_dt_juno_rom.c")
+
+ # no need to add header files to DT defines for this module
+
+endif()
+
target_link_libraries(${SCP_MODULE_TARGET} PRIVATE module-juno-ppu)
target_link_libraries(${SCP_MODULE_TARGET} PRIVATE module-power-domain)
target_link_libraries(${SCP_MODULE_TARGET} PRIVATE module-bootloader)