summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-08-16 21:40:18 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-18 19:06:50 -0300
commit22f24693bc4302f31a7fcc237502f21f64eb828d (patch)
tree6b6bff265b6e0a560d6efa0743db97df2f69eb7d
parentc1d61e5bdc64a14a2afe4ed17dbfdb38af2a055a (diff)
firefox: prevent SIGILL crash with arm build
Firefox crashes with a SIGILL signal during startup. Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-mozilla/firefox/firefox/alignment.patch17
-rw-r--r--recipes-mozilla/firefox/firefox_10.0.11esr.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/recipes-mozilla/firefox/firefox/alignment.patch b/recipes-mozilla/firefox/firefox/alignment.patch
new file mode 100644
index 0000000..f5d5b7c
--- /dev/null
+++ b/recipes-mozilla/firefox/firefox/alignment.patch
@@ -0,0 +1,17 @@
+In some setups firefox crashes because of wrongly aligned variables
+Observed on a ARM Cortex-A9 target.
+
+Upstream-Status: Pending
+
+Signed-off-by: Max Krummenacher <max.oss.09 at gmail.com>
+--- mozilla-release/ipc/ipdl/ipdl/cxx/cgen.py~ 2012-07-29 11:14:45.000000000 +0200
++++ mozilla-release/ipc/ipdl/ipdl/cxx/cgen.py 2012-07-29 11:13:36.000000000 +0200
+@@ -107,7 +107,7 @@
+ self.println(';')
+ self.dedent()
+
+- self.printdent('}')
++ self.printdent('} __attribute__ ((aligned (__BIGGEST_ALIGNMENT__)))')
+
+
+ def visitTypedef(self, td):
diff --git a/recipes-mozilla/firefox/firefox_10.0.11esr.bb b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
index e07555b..cb368d0 100644
--- a/recipes-mozilla/firefox/firefox_10.0.11esr.bb
+++ b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
@@ -75,7 +75,8 @@ SRC_URI = "https://archive.mozilla.org/pub/firefox/releases/${PV}/source/firefox
file://powerpc_va_list.patch \
file://freetype-2.5.patch \
file://x86_64-fix.patch \
- file://vendor.js"
+ file://vendor.js \
+ file://alignment.patch"
SRC_URI[archive.md5sum] = "2f0e3a1dd7480e03f374c0121b4155e2"
SRC_URI[archive.sha256sum] = "94b4d5a339d97dc56fd349f93407c3af4f408a4a8409a64e3680d564d37594f8"