summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-08-16 21:40:19 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-18 19:06:50 -0300
commit6c3b2568f9eaa8eca4a578089767297b84efc99f (patch)
tree9dac84459a75b55a4929a51d27cb6be59805351f
parent22f24693bc4302f31a7fcc237502f21f64eb828d (diff)
firefox: prevent SIGILL crash #2 with arm build
Firefox built with oe-core, daisy, crashes with a SIGILL signal during startup. No window is drawn, crash starts somewere in js/src/methodjit/MethodJIT.cpp JaegerCompartment::Initialize() The patch from https://bugzilla.mozilla.org/show_bug.cgi?id=803601#c28 fixes this. Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-mozilla/firefox/firefox/Prevent-SIGILL-crashes-on-ARMv6-builds-built-with-the-NDK_10.0esr.patch89
-rw-r--r--recipes-mozilla/firefox/firefox_10.0.11esr.bb3
2 files changed, 91 insertions, 1 deletions
diff --git a/recipes-mozilla/firefox/firefox/Prevent-SIGILL-crashes-on-ARMv6-builds-built-with-the-NDK_10.0esr.patch b/recipes-mozilla/firefox/firefox/Prevent-SIGILL-crashes-on-ARMv6-builds-built-with-the-NDK_10.0esr.patch
new file mode 100644
index 0000000..e00d2d5
--- /dev/null
+++ b/recipes-mozilla/firefox/firefox/Prevent-SIGILL-crashes-on-ARMv6-builds-built-with-the-NDK_10.0esr.patch
@@ -0,0 +1,89 @@
+firefox crashes with a fix SIGILL abort on start.
+
+This seems to happen only in some setups. (e.g. with gcc provided from
+meta-linaro, 4.8.3, with a meta-fsl-arm setup + meta-browser firefox
+starts correctly (with gcc from oe, meta-oe, 4.8.2))
+
+The following patch fixes this:
+https://hg.mozilla.org/integration/mozilla-inbound/rev/f9be5a3d9b3c
+
+Signed-off-by: Max Krummenacher <max.oss.09 at gmail.com>
+
+# HG changeset patch
+# User Kartikaya Gupta <kgupta@mozilla.com>
+# Date 1356843815 18000
+# Node ID f9be5a3d9b3ce26ad94e31a4c0275fee19db7ca8
+# Parent 414b431ad3fa831ecf5bf69abd3b5cb8670781db
+Bug 803601 - Prevent SIGILL crashes on ARMv6 builds built with the NDK r8c toolchain (gcc-4.6, gold). r=mjrosenb
+
+diff --git a/js/src/methodjit/MethodJIT.cpp b/js/src/methodjit/MethodJIT.cpp
+--- a/js/src/methodjit/MethodJIT.cpp
++++ b/js/src/methodjit/MethodJIT.cpp
+@@ -671,8 +671,10 @@
+ ".align 2\n" \
+ ".thumb\n" \
+ ".thumb_func\n"
++#define BRANCH_AND_LINK(x) "blx " x
+ #else
+ #define FUNCTION_HEADER_EXTRA
++#define BRANCH_AND_LINK(x) "bl " x
+ #endif
+
+ asm (
+@@ -731,9 +733,9 @@
+ " mov r10, r1" "\n"
+
+ " mov r0, sp" "\n"
+-" blx " SYMBOL_STRING_VMFRAME(SetVMFrameRegs) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_VMFRAME(SetVMFrameRegs)) "\n "
+ " mov r0, sp" "\n"
+-" blx " SYMBOL_STRING_VMFRAME(PushActiveVMFrame)"\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_VMFRAME(PushActiveVMFrame)) "\n"
+
+ /* Call the compiled JavaScript function. */
+ " bx r4" "\n"
+@@ -748,7 +750,7 @@
+
+ /* Tidy up. */
+ " mov r0, sp" "\n"
+-" blx " SYMBOL_STRING_VMFRAME(PopActiveVMFrame) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_VMFRAME(PopActiveVMFrame)) "\n"
+
+ /* Skip past the parameters we pushed (such as cx and the like). */
+ " add sp, sp, #(4*7 + 4*6)" "\n"
+@@ -767,7 +769,7 @@
+ " mov r0, sp" "\n"
+
+ /* Call the utility function that sets up the internal throw routine. */
+-" blx " SYMBOL_STRING_RELOC(js_InternalThrow) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_RELOC(js_InternalThrow)) "\n"
+
+ /* If js_InternalThrow found a scripted handler, jump to it. Otherwise, tidy
+ * up and return. */
+@@ -777,7 +779,7 @@
+
+ /* Tidy up, then return '0' to represent an unhandled exception. */
+ " mov r0, sp" "\n"
+-" blx " SYMBOL_STRING_VMFRAME(PopActiveVMFrame) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_VMFRAME(PopActiveVMFrame)) "\n"
+ " add sp, sp, #(4*7 + 4*6)" "\n"
+ " mov r0, #0" "\n"
+ " pop {r4-r11,pc}" "\n"
+@@ -801,7 +803,7 @@
+ " mov r2, r0" "\n" /* returnReg */
+ " mov r1, r5" "\n" /* returnType */
+ " mov r0, r4" "\n" /* returnData */
+-" blx " SYMBOL_STRING_RELOC(js_InternalInterpret) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_RELOC(js_InternalInterpret)) "\n"
+ " cmp r0, #0" "\n"
+ " ldr r10, [sp, #(4*7)]" "\n" /* Load (StackFrame*)f->regs->fp_ */
+ " ldrd r4, r5, [r10, #(4*6)]" "\n" /* Load rval payload and type. */
+@@ -810,7 +812,7 @@
+ " bxne r0" "\n"
+ /* Tidy up, then return 0. */
+ " mov r0, sp" "\n"
+-" blx " SYMBOL_STRING_VMFRAME(PopActiveVMFrame) "\n"
++" " BRANCH_AND_LINK(SYMBOL_STRING_VMFRAME(PopActiveVMFrame)) "\n"
+ " add sp, sp, #(4*7 + 4*6)" "\n"
+ " mov r0, #0" "\n"
+ " pop {r4-r11,pc}" "\n"
diff --git a/recipes-mozilla/firefox/firefox_10.0.11esr.bb b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
index cb368d0..8a99b77 100644
--- a/recipes-mozilla/firefox/firefox_10.0.11esr.bb
+++ b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
@@ -76,7 +76,8 @@ SRC_URI = "https://archive.mozilla.org/pub/firefox/releases/${PV}/source/firefox
file://freetype-2.5.patch \
file://x86_64-fix.patch \
file://vendor.js \
- file://alignment.patch"
+ file://alignment.patch \
+ file://Prevent-SIGILL-crashes-on-ARMv6-builds-built-with-the-NDK_10.0esr.patch"
SRC_URI[archive.md5sum] = "2f0e3a1dd7480e03f374c0121b4155e2"
SRC_URI[archive.sha256sum] = "94b4d5a339d97dc56fd349f93407c3af4f408a4a8409a64e3680d564d37594f8"