summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-08-16 21:40:21 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-18 19:06:50 -0300
commitf74c807017e8e63de0ab5485731eaf5c69af0ce8 (patch)
treeba42bdc4df6874b579078ea2f7817ada2d3e0bcb
parent0b1fcf45ebe30d5ced856ae9ba1d109dc614188f (diff)
mozilla.bbclass: do out of tree build
Do a out of tree build by setting MOZ_OBJDIR to something != ${S}. Newer firefox do no longer allow do build in tree. Change firefox_10.0.11esr.bb accordingly. Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--classes/mozilla.bbclass2
-rw-r--r--recipes-mozilla/firefox/firefox_10.0.11esr.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/classes/mozilla.bbclass b/classes/mozilla.bbclass
index f9a84aa..940f381 100644
--- a/classes/mozilla.bbclass
+++ b/classes/mozilla.bbclass
@@ -12,7 +12,7 @@ SELECTED_OPTIMIZATION = "-Os -fsigned-char -fno-strict-aliasing"
export CROSS_COMPILE = "1"
export MOZCONFIG = "${WORKDIR}/mozconfig"
-export MOZ_OBJDIR = "${S}"
+export MOZ_OBJDIR = "${WORKDIR}/obj-${TARGET_SYS}"
export CONFIGURE_ARGS = "${EXTRA_OECONF}"
export HOST_CC = "${BUILD_CC}"
diff --git a/recipes-mozilla/firefox/firefox_10.0.11esr.bb b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
index 07226ff..94bd4be 100644
--- a/recipes-mozilla/firefox/firefox_10.0.11esr.bb
+++ b/recipes-mozilla/firefox/firefox_10.0.11esr.bb
@@ -91,7 +91,7 @@ EXTRA_OEMAKE = "installdir=${libdir}/${PN}"
ARM_INSTRUCTION_SET = "arm"
do_install() {
- oe_runmake DESTDIR="${D}" destdir="${D}" install
+ oe_runmake -C "${MOZ_OBJDIR}" DESTDIR="${D}" destdir="${D}" install
install -d ${D}${datadir}/applications
install -d ${D}${datadir}/pixmaps
install -m 0644 ${WORKDIR}/mozilla-firefox.desktop ${D}${datadir}/applications/