summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-browser/chromium/chromium/google-chrome9
-rw-r--r--recipes-browser/chromium/chromium_35.0.1883.0.bb6
2 files changed, 11 insertions, 4 deletions
diff --git a/recipes-browser/chromium/chromium/google-chrome b/recipes-browser/chromium/chromium/google-chrome
index 8ce400b..78f4a29 100644
--- a/recipes-browser/chromium/chromium/google-chrome
+++ b/recipes-browser/chromium/chromium/google-chrome
@@ -3,8 +3,9 @@
export CHROME_DEVEL_SANDBOX=/usr/sbin/chrome-devel-sandbox
export LD_LIBRARY_PATH=/usr/lib/chrome
-if [ "${USER}" = "root" ] ; then
- /usr/bin/chrome/chrome --user-data-dir=${HOME}/.chromium/ $@
-else
- /usr/bin/chrome/chrome $@
+CHROME_EXTRA_ARGS=""
+if [ "${USER}" = "root" ] ; then
+ CHROME_EXTRA_ARGS="${CHROME_EXTRA_ARGS} --user-data-dir=${HOME}/.chromium/"
fi
+
+/usr/bin/chrome/chrome ${CHROME_EXTRA_ARGS} $@
diff --git a/recipes-browser/chromium/chromium_35.0.1883.0.bb b/recipes-browser/chromium/chromium_35.0.1883.0.bb
index 96d3344..5f4e807 100644
--- a/recipes-browser/chromium/chromium_35.0.1883.0.bb
+++ b/recipes-browser/chromium/chromium_35.0.1883.0.bb
@@ -33,6 +33,8 @@ EXTRA_OEGYP = " \
"
ARMFPABI_armv7a = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'arm_float_abi=hard', 'arm_float_abi=softfp', d)}"
+CHROMIUM_EXTRA_ARGS ?= ""
+
export GYP_DEFINES="${ARMFPABI} release_extra_cflags='-Wno-error=unused-local-typedefs' sysroot=''"
do_configure() {
cd ${S}
@@ -54,6 +56,10 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/google-chrome ${D}${bindir}/
+ # Add extra command line arguments to google-chrome script by modifying
+ # the dummy "CHROME_EXTRA_ARGS" line
+ sed -i "s/^CHROME_EXTRA_ARGS=\"\"/CHROME_EXTRA_ARGS=\"${CHROMIUM_EXTRA_ARGS}\"/" ${D}${bindir}/google-chrome
+
install -d ${D}${datadir}/applications
install -m 0644 ${WORKDIR}/google-chrome.desktop ${D}${datadir}/applications/