summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMartin Wolf <ext-martin.2.wolf@nokia.com>2010-02-03 10:13:44 +0200
committerMartin Wolf <ext-martin.2.wolf@nokia.com>2010-02-03 10:13:44 +0200
commit06644af1a621f2afbd42957afc9cfda24056df54 (patch)
treedac557aab7a7bff21ad7b7c0ccc877bf42f5303e /debian
parent8bff62c335842b4c850cc09716e79c2f556247c7 (diff)
Added debian packaging info and libdbus-qeventloop library
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control43
-rw-r--r--debian/libdbus-qeventloop-dev.install1
-rw-r--r--debian/libdbus-qeventloop0.install1
-rw-r--r--debian/libresourceqt-dev.install1
-rw-r--r--debian/libresourceqt-tests.install2
-rw-r--r--debian/libresourceqt0.install1
-rwxr-xr-xdebian/rules105
9 files changed, 160 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5fc5a2e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+libresourceqt (0.1) unstable; urgency=low
+
+ * First release
+
+ -- Martin Wolf <ext-martin.2.wolf@nokia.com> Fri, 29 Jan 2010 12:00:00 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..bf0d87a
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4 \ No newline at end of file
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..dd27f2d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,43 @@
+Source: libresourceqt
+Priority: extra
+Maintainer: Martin Wolf <ext-martin.2.wolf@nokia.com>
+Build-Depends: debhelper (>= 5), libqt4-dev (>= 4.5), libdbus-1-dev
+Standards-Version: 3.8.0
+Section: libs
+
+Package: libresourceqt-dev
+Section: libdevel
+Architecture: any
+Depends: libresourceqt0 (= ${binary:Version})
+Description: Development package for libresourceqt
+ Includes development files for libresourceqt.
+
+Package: libresourceqt0
+Section: libs
+Architecture: any
+Depends: libdbus-qeventloop0, ${shlibs:Depends}, ${misc:Depends}
+Description: libresourceqt library
+ Contains library files for the application that use libresourceqt
+
+Package: libdbus-qeventloop-dev
+Section: libdevel
+Architecture: any
+Depends: libdbus-qeventloop0 (= ${binary:Version})
+Description: Development package for libdbus-qeventloop
+ Includes development files for libdbus-qeventloop.
+
+Package: libdbus-qeventloop0
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: libdbus-qeventloop library
+ Contains library files for the application that use libdbus-qeventloop
+
+Package: libresourceqt-tests
+Section: misc
+Depends: testrunner, libresourceqt0, libdbus-qeventloop0, ${shlibs:Depends}
+XB-Maemo-CI-Packages: libresourceqt0, libdbus-qeventloop0
+XB-Maemo-CI-Stage: fast, staging, acceptance
+Architecture: any
+Description: libresourceqt0 and libdbus-qeventloop test package
+ This package contains tests which can be used in CI environment
diff --git a/debian/libdbus-qeventloop-dev.install b/debian/libdbus-qeventloop-dev.install
new file mode 100644
index 0000000..facc538
--- /dev/null
+++ b/debian/libdbus-qeventloop-dev.install
@@ -0,0 +1 @@
+usr/include/resource/qt4/dbus*
diff --git a/debian/libdbus-qeventloop0.install b/debian/libdbus-qeventloop0.install
new file mode 100644
index 0000000..f960cda
--- /dev/null
+++ b/debian/libdbus-qeventloop0.install
@@ -0,0 +1 @@
+usr/lib/libdbus-qeventloop*.so*
diff --git a/debian/libresourceqt-dev.install b/debian/libresourceqt-dev.install
new file mode 100644
index 0000000..1e9ea18
--- /dev/null
+++ b/debian/libresourceqt-dev.install
@@ -0,0 +1 @@
+usr/include/resource/qt4/resource* \ No newline at end of file
diff --git a/debian/libresourceqt-tests.install b/debian/libresourceqt-tests.install
new file mode 100644
index 0000000..2144fbf
--- /dev/null
+++ b/debian/libresourceqt-tests.install
@@ -0,0 +1,2 @@
+usr/lib/libresourceqt-tests/*
+usr/share/libresourceqt-tests/* \ No newline at end of file
diff --git a/debian/libresourceqt0.install b/debian/libresourceqt0.install
new file mode 100644
index 0000000..c09c3e8
--- /dev/null
+++ b/debian/libresourceqt0.install
@@ -0,0 +1 @@
+usr/lib/libresourceqt*.so*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..aff3d26
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,105 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+
+
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+# shared library versions, option 1
+version=2.0.5
+major=2
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/build/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/build/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+
+ qmake
+
+ touch configure-stamp
+
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) distclean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ INSTALL_ROOT=$(CURDIR)/debian/tmp make install
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp -v
+
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure \ No newline at end of file