summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules83
1 files changed, 83 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4f60f2e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,83 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+%:
+ dh $@
+
+#include /usr/share/cdbs/1/rules/debhelper.mk
+#include /usr/share/cdbs/1/class/qmake.mk
+
+
+DEB_SOURCE := $(shell dpkg-parsechangelog | grep Source: | sed -e 's/Source: //')
+DEB_VERSION := $(shell dpkg-parsechangelog | grep Version: | sed -e 's/Version: //')
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_VERSION) | sed -e 's/-[^-]*$$//')
+DEB_MAJOR_VERSION := $(shell echo $(DEB_UPSTREAM_VERSION) | sed -e 's/git.*//')
+
+GIT_URL := git://gitorious.org/maemo-multimedia/libresourceqt
+GIT_BRANCH := "master"
+GIT_BRANCH_NAME := libresourceqt
+
+ifneq (,$(LOCAL_BRANCH))
+LOCAL_REAL_BRANCH = $(realpath $(LOCAL_BRANCH))
+endif
+
+
+PACKAGENAME=libresourceqt
+
+GET_SOURCE = \
+ set -e; \
+ tmpdir=`mktemp -d -t`; \
+ cd $$tmpdir; \
+ echo "cloning upstream repository ..."; \
+ git clone -b $(GIT_BRANCH) $(if $(LOCAL_BRANCH),$(call LOCAL_REAL_BRANCH)/$(GIT_BRANCH_NAME),$(GIT_URL)) $(GIT_BRANCH_NAME); \
+ echo "getting specific upstream revision/tag: $(1)"; \
+ cd `ls | head -n 1`; git checkout -b orig $(1); \
+ commit_id=`git log -n1 --abbrev-commit | grep '^commit ' | sed -e 's/commit //' | sed -e 's/\.\.\.$$//'`; \
+ raw=`date --utc --date="$$(git log --pretty=fuller -n1 --date=rfc | grep CommitDate: | sed -e 's/CommitDate:[^0-9]*//')" "+%Y%m%dt%H%M%S"`; \
+ if echo $(2) | grep -q -c "orig" || echo $(DEB_VERSION) | grep -q -c "git"; \
+ then \
+ upstream_version=$(DEB_MAJOR_VERSION)-git.$$raw.$$commit_id; \
+ else \
+ upstream_version=$(DEB_UPSTREAM_VERSION); \
+ fi; \
+ cd ..; tar --exclude=.git -czf $(CURDIR)/$(DEB_SOURCE)_$$upstream_version.orig.tar.gz `ls | head -n 1`; \
+ cd $(CURDIR); rm -rf $$tmpdir;
+
+
+get-current-source:: $(if $(LOCAL_BRANCH),update-local-branch)
+ set -e; if echo $(DEB_VERSION) | grep -q -c "git"; \
+ then \
+ git_version=`echo $(DEB_VERSION) | sed -e 's/^.*git\.*\([0-9t]*\)\.\(.*\)-.*$$/\2/g'`; \
+ elif echo $(DEB_VERSION) | grep -q -c "~rc"; \
+ then \
+ git_version=`echo $(DEB_VERSION) | sed -e 's/^\([0-9\.]*\)\(~rc\)\([0-9]\)-.*$$/\1-rc\3/'`; \
+ else \
+ git_version=$(DEB_UPSTREAM_VERSION); \
+ fi; \
+ $(call GET_SOURCE, $$git_version, "current")
+
+get-orig-source:: $(if $(LOCAL_BRANCH),update-local-branch)
+ $(call GET_SOURCE, "HEAD", "orig")
+
+update-local-branch::
+ @echo "updating local branch ($(LOCAL_BRANCH))"
+ @set -e; if ! test -d $(LOCAL_BRANCH); then mkdir -p $(LOCAL_BRANCH); fi
+ @set -e; if ! test -d $(LOCAL_BRANCH)/$(GIT_BRANCH_NAME); then git clone $(GIT_URL) $(LOCAL_BRANCH)/$(GIT_BRANCH_NAME); fi
+ @set -e; cd $(LOCAL_BRANCH)/$(GIT_BRANCH_NAME); if ! `git branch | grep -q -c "$(GIT_BRANCH)"`; then git branch $(GIT_BRANCH) remotes/origin/$(GIT_BRANCH); fi
+ @set -e; cd $(LOCAL_BRANCH)/$(GIT_BRANCH_NAME); git checkout $(GIT_BRANCH); git pull -f
+ @echo "updated local branch ($(LOCAL_BRANCH))"
+
+get-snapshot-info:: $(if $(LOCAL_BRANCH),update-local-branch)
+ @set -e; \
+ git_version=`echo $(DEB_VERSION) | sed -e 's/^.*git\.*\([0-9t]*\)\.\(.*\)-.*$$/\2/g'`; \
+ cd $(LOCAL_BRANCH)/$(GIT_BRANCH_NAME); \
+ raw=`date --utc --date="$$(git log --pretty=fuller -n1 --date=rfc $$git_version | grep CommitDate: | sed -e 's/CommitDate:[^0-9]*//')" "+%Y-%m-%d %H:%M:%S (GMT)"`; \
+ git log -n1 $$git_version --format="%n%s%n%n * upstream snapshot $$raw%n + %H%n";