summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-05-18 17:07:48 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-05-23 18:15:07 -0300
commitabe479606e0eb65efeaa9b5d3f3f7e8eb77c05dd (patch)
tree7a9433bb4326fd1441064f33eb61a5607f7c90be /recipes-core
parentd5f4edc746d21831369d5947fc3dff0346e84684 (diff)
initramfs-ostree-osf-image: unset EXTRA_IMAGEDEPENDS to avoid circular dependencies
Initrd doesn't need to have EXTRA_IMAGEDEPENDS as that can trigger circular dependencies when INITRAMFS_IMAGE_BUNDLE is used (as the kernel will depend on the initrd image complete task, which will depend on EXTRA_IMAGEDEPENDS sysroot tasks, and if one of those tasks also depend on the kernel build to finish, it creates a circular dependency). Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/initramfs-ostree-osf-image.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-osf-image.bb b/recipes-core/images/initramfs-ostree-osf-image.bb
index ba3153a..3db5500 100644
--- a/recipes-core/images/initramfs-ostree-osf-image.bb
+++ b/recipes-core/images/initramfs-ostree-osf-image.bb
@@ -15,6 +15,9 @@ LICENSE = "MIT"
IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}"
IMAGE_FSTYPES_remove = "wic wic.gz wic.bmap ext4 ext4.gz"
+# avoid circular dependencies
+EXTRA_IMAGEDEPENDS = ""
+
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"