summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-02-20 21:05:06 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-03-27 22:10:35 -0300
commite6c1424d15bc50e090fbf4a8527f062878f1eec0 (patch)
tree9936864c3b93ccf28c3615ce4c67e7a4470f2ec0 /recipes-core
parentac64ce66cd633ad3623bc683a4400ab8c868ccdf (diff)
initramfs-ostree-osf-image: add new initramfs image for ostree
OSTree initramfs image that uses the initramfs OE-Core infrastructure. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/initramfs-ostree-osf-image.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-osf-image.bb b/recipes-core/images/initramfs-ostree-osf-image.bb
new file mode 100644
index 0000000..ba3153a
--- /dev/null
+++ b/recipes-core/images/initramfs-ostree-osf-image.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "OSF OSTree initramfs image"
+
+PACKAGE_INSTALL = "initramfs-framework-base initramfs-module-udev initramfs-module-rootfs initramfs-module-debug initramfs-module-ostree ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+SYSTEMD_DEFAULT_TARGET = "initrd.target"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-ostree-osf-image"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${OSTREE_INITRAMFS_FSTYPES}"
+IMAGE_FSTYPES_remove = "wic wic.gz wic.bmap ext4 ext4.gz"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# Users will often ask for extra space in their rootfs by setting this
+# globally. Since this is a initramfs, we don't want to make it bigger
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+IMAGE_OVERHEAD_FACTOR = "1.0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"