summaryrefslogtreecommitdiff
path: root/clang-tools-extra/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang-tools-extra/test/CMakeLists.txt')
-rw-r--r--clang-tools-extra/test/CMakeLists.txt16
1 files changed, 6 insertions, 10 deletions
diff --git a/clang-tools-extra/test/CMakeLists.txt b/clang-tools-extra/test/CMakeLists.txt
index a1bda509089..e2d7e12ef19 100644
--- a/clang-tools-extra/test/CMakeLists.txt
+++ b/clang-tools-extra/test/CMakeLists.txt
@@ -56,18 +56,14 @@ set(CLANG_TOOLS_TEST_DEPS
# Unit tests
ExtraToolsUnitTests
- )
-if(CLANG_ENABLE_STATIC_ANALYZER)
- list(APPEND CLANG_TOOLS_TEST_DEPS
- # For the clang-tidy libclang integration test.
- c-index-test
- # clang-tidy tests require it.
- clang-headers
+ # For the clang-tidy libclang integration test.
+ c-index-test
+ # clang-tidy tests require it.
+ clang-headers
- clang-tidy
- )
-endif()
+ clang-tidy
+ )
add_lit_testsuite(check-clang-tools "Running the Clang extra tools' regression tests"
${CMAKE_CURRENT_BINARY_DIR}