aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2012-06-08 10:55:34 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-06-08 10:55:34 +0200
commitdbf0e6292e0150c8e289c20edfc908f2b2c26738 (patch)
treeded086e6b2dbd26277db8cbe6cd6f3a05fc37979 /debian
parent322f46ed3804f63665d97700b2205309c67f3c85 (diff)
debian/gst-codec-info.c: Updated for API changesdebian/0.11.92-1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/gst-codec-info.c17
2 files changed, 14 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1b52b84..1cc72a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ gstreamer1.0 (0.11.92-1) experimental; urgency=low
* New upstream release, "High Hopes":
+ debian/libgstreamer.symbols:
- Update symbols file.
+ * debian/gst-codec-info.c:
+ + Updated for API changes.
-- Sebastian Dröge <slomo@debian.org> Fri, 08 Jun 2012 09:38:04 +0200
diff --git a/debian/gst-codec-info.c b/debian/gst-codec-info.c
index f1973b3..7f0f03f 100644
--- a/debian/gst-codec-info.c
+++ b/debian/gst-codec-info.c
@@ -150,10 +150,10 @@ static void
cleanup_plugin_info (void)
{
if (encoders)
- gst_caps_simplify (encoders);
+ encoders = gst_caps_simplify (encoders);
if (decoders)
- gst_caps_simplify (decoders);
+ decoders = gst_caps_simplify (decoders);
elements = g_list_sort (elements, (GCompareFunc) strcmp);
uri_sources = g_list_sort (uri_sources, (GCompareFunc) strcmp);
@@ -169,7 +169,7 @@ cleanup_plugin_info (void)
static void
collect_uri_protocols (GstElementFactory * factory)
{
- gchar **protocols, **p;
+ const gchar *const *protocols, *const *p;
protocols = gst_element_factory_get_uri_protocols (factory);
if (!protocols)
@@ -184,8 +184,9 @@ collect_uri_protocols (GstElementFactory * factory)
for (p = protocols; *p; p++)
uri_sources = g_list_prepend (uri_sources, g_strdup (*p));
break;
+ default:
+ break;
}
- g_strfreev (protocols);
}
static void
@@ -379,9 +380,15 @@ collect_plugin_info (GstPlugin * plugin)
for (l = features; l; l = l->next) {
GstPluginFeature *feature = GST_PLUGIN_FEATURE (l->data);
GstElementFactory *factory = GST_ELEMENT_FACTORY (feature);
+ GstPlugin *f_plugin = gst_plugin_feature_get_plugin (feature);
- if (!g_str_equal (plugin_name, feature->plugin_name))
+ if (!f_plugin)
+ continue;
+ if (!g_str_equal (plugin_name, gst_plugin_get_name (f_plugin))) {
+ gst_object_unref (f_plugin);
continue;
+ }
+ gst_object_unref (f_plugin);
elements =
g_list_prepend (elements,