aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py57
1 files changed, 57 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..23e4095
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,57 @@
+#!/usr/bin/env python
+#
+# Copyright (C) 2015 Linaro Limited
+#
+# Author: Senthil Kumaran S <senthil.kumaran@linaro.org>
+#
+# This file is part of Linaro LAVA LDAP.
+#
+# Linaro LAVA LDAP is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License version 3
+# as published by the Free Software Foundation
+#
+# Linaro LAVA LDAP is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with Linaro LAVA LDAP. If not, see <http://www.gnu.org/licenses/>.
+
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name='linaro_lava_ldap',
+ version=":versiontools:linaro_lava_ldap:__version__",
+ author="Senthil Kumaran S",
+ author_email="lava-team@linaro.org",
+ packages=find_packages(),
+ license="AGPL",
+ description="Linaro LAVA LDAP",
+ long_description="""
+ Linaro login service customizations for LAVA server
+ """,
+ url='http://www.linaro.org/engineering/engineering-groups/validation',
+ classifiers=[
+ "Development Status :: 0.1",
+ "Intended Audience :: Administrators",
+ "License :: OSI Approved :: GNU Affero General Public License v3",
+ ("License :: OSI Approved :: GNU Library or Lesser General Public"
+ " License (LGPL)"),
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Software Development :: Testing",
+ ],
+ install_requires=[
+ 'django >= 1.6.1',
+ 'django-auth-ldap >= 1.2',
+ 'django-restricted-resource >= 0.2.7',
+ 'django-tables2 >= 0.13.0',
+ 'docutils >= 0.6',
+ 'versiontools >= 1.8',
+ 'psycopg2',
+ ],
+ zip_safe=True)