aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Harkin <ryan.harkin@linaro.org>2020-05-06 14:58:48 +0100
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2020-05-06 20:54:16 +0200
commit20322e9ca90fb76b17502136f2598fe09f66e2f7 (patch)
treebec57a7bbca9cd6881d7ef469724a32d6a1da648
parentabf07d7f79323e0813c27152e7263cf183800477 (diff)
layer.conf: use BBFILES_DYNAMICwarrior
Only include .bbappend and .bb files for layers already present in BBFILES_DYNAMIC. This prevents build failures from attempting to patch layers that do not exist. Signed-off-by: Ryan Harkin <ryan.harkin@linaro.org> Change-Id: I252c4d2b54f1ef93480c32a68d0f4d3ed5c4054a (cherry picked from commit bcf91bc2850790aec41e6dc10aa58b6e8fc4617c) Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--conf/layer.conf4
1 files changed, 2 insertions, 2 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 66fd99b..fe3ccb3 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,8 +9,8 @@ LAYERSERIES_COMPAT_backports = "warrior"
# Let us add layer-specific bbappends which are only applied when that
# layer is included in our configuration
# includes customization and/or backports
-BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+BBFILES_DYNAMIC += "${@' '.join('%s:${LAYERDIR}/%s/recipes*/*/*.bbappend' % (layer, layer) \
for layer in BBFILE_COLLECTIONS.split())}"
# Add layer-specific bb files too
-BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+BBFILES_DYNAMIC += "${@' '.join('%s:${LAYERDIR}/%s/recipes*/*/*.bb' % (layer, layer) \
for layer in BBFILE_COLLECTIONS.split())}"