aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 664cee5adf4..98999886ef9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,10 +59,14 @@ clean: debian/control
# This gets rid of the d-i packages in control
cp -f $(DEBIAN)/control.stub $(DEBIAN)/control
- cp $(DEBIAN)/changelog debian/changelog
+ cp -p $(DEBIAN)/changelog debian/changelog
# Install the copyright information.
- cp $(DEBIAN)/copyright debian/copyright
+ cp -p $(DEBIAN)/copyright debian/copyright
+
+ touch -r $(DEBIAN)/control.stub.in $(DEBIAN)/control $(DEBIAN)/control.stub debian/control debian/control.stub
+ touch -r $(DEBIAN)/d-i/kernel-versions.in $(DEBIAN)/d-i/kernel-versions
+ touch -r $(DEBIAN)/changelog debian
distclean: clean
rm -rf $(DEBIAN)/control $(DEBIAN)/control.stub \