aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2011-08-24 09:44:01 -0600
committerLinaro CI <john.rigby@linaro.org>2012-02-07 22:48:12 +0000
commit2bfd73273085ac7f4f1839e7844ad6f8e8229079 (patch)
tree5646cb55c956e62c52545d5de729252ea8af3c41 /debian
parent992563030d8fed8adc9010bb9e714cc9272e392e (diff)
UBUNTU: [Config] Restore prepare-% target
It turns out that some tossers like to shortcut the process during development. A common sequence for a quick compile test is to preapre the tree, copy the .config, then perform an in-tree compile. For example, fakeroot debian/rules clean prepare-generic cp debian/build/build-generic/.config . make oldconfig scripts prepare make M=`pwd`/fs/ext4 Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 5091dc431f3..d0f31f33192 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -24,6 +24,10 @@ $(stampdir)/stamp-prepare-tree-%: $(commonconfdir)/config.common.$(family) $(arc
$(build_cd) $(kmake) $(build_O) -j1 silentoldconfig prepare scripts
touch $@
+# Used by developers as a shortcut to prepare a tree for compilation.
+prepare-%: $(stampdir)/stamp-prepare-%
+ @echo Prepared $* for $(arch)
+
# Do the actual build, including image and modules
$(stampdir)/stamp-build-%: target_flavour = $*
$(stampdir)/stamp-build-%: $(stampdir)/stamp-prepare-%