aboutsummaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authorRasmus Villemoes <rv@rasmusvillemoes.dk>2018-06-27 10:04:25 +0000
committerRasmus Villemoes <rv@rasmusvillemoes.dk>2018-06-27 10:04:25 +0000
commit54eef27748fd3e9d9521400ebe95c82d849f5ed2 (patch)
tree12e1333e335da0d5357ee4418e40356b5c9ab765 /libgcc/configure.ac
parent7aefe554dd100382d730f8711b67dd92d9283ede (diff)
add support for --disable-gcov
For some targets (in my case VxWorks 5.5), libgcov does not compile due to missing functions and macros such as getpid() and F_OK. Incidentally, gcc/Makefile.in already contains comments such as # Install gcov if it was compiled. but there is no logic in place to actually allow gcov to not be compiled. So add an option for disabling build and install of libgcov and the related host tools. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@262180 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index b59aa746afc..9d0bbcaba86 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -68,6 +68,11 @@ AC_ARG_ENABLE(shared,
], [enable_shared=yes])
AC_SUBST(enable_shared)
+AC_ARG_ENABLE(gcov,
+[ --disable-gcov don't provide libgcov and related host tools],
+[], [enable_gcov=yes])
+AC_SUBST(enable_gcov)
+
AC_ARG_ENABLE(vtable-verify,
[ --enable-vtable-verify Enable vtable verification feature ],
[case "$enableval" in