aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 83e23a1e648..07b16ba42f1 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3366,7 +3366,9 @@ changequote([,])dnl
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gmon.o crtbegin.o crtend.o"
case $machine in
+changequote(,)dnl
*-*-solaris2.[0-4])
+changequote([,])dnl
float_format=i128
;;
*)
@@ -3703,16 +3705,16 @@ changequote([,])dnl
then
if test x$gnu_ld = xyes
then
- target_cpu_default2=20
+ target_cpu_default2="MASK_GAS|MASK_SPLIT_ADDR"
else
- target_cpu_default2=16
+ target_cpu_default2="MASK_GAS"
fi
fi
;;
mips*-*-*)
if test x$gas = xyes
then
- target_cpu_default2=16
+ target_cpu_default2="MASK_GAS"
fi
;;
powerpc*-*-* | rs6000-*-*)