aboutsummaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index e1d88511c78..83d5bb6e827 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -33,12 +33,16 @@ AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
# Figure out what compiler warnings we can enable.
# See config/warnings.m4 for details.
-ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings \
+ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wno-narrowing -Wwrite-strings \
-Wmissing-format-attribute], [warn])
ACX_PROG_CC_WARNING_OPTS([-Wstrict-prototypes -Wmissing-prototypes \
-Wold-style-definition -Wc++-compat], [c_warn])
ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
+# Disable exceptions and RTTI if building with g++
+ACX_PROG_CC_WARNING_OPTS(
+ m4_quote(m4_do([-fno-exceptions -fno-rtti])), [noexception_flags])
+
# Only enable with --enable-werror-always until existing warnings are
# corrected.
ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual])