aboutsummaryrefslogtreecommitdiff
path: root/meta-oe/recipes-extended/fwts/fwts_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/fwts/fwts_git.bb')
-rw-r--r--meta-oe/recipes-extended/fwts/fwts_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fwts/fwts_git.bb b/meta-oe/recipes-extended/fwts/fwts_git.bb
new file mode 100644
index 00000000..4f88f236
--- /dev/null
+++ b/meta-oe/recipes-extended/fwts/fwts_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Firmware testsuite"
+DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
+HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=deb8af5388e838d133eaa036f4d1496f"
+
+PV = "14.01.00"
+
+SRCREV = "fef72314787d7b029d932ef56b4a117538cf69e3"
+SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
+ file://subdir.patch \
+ file://jsonc.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libpcre json-c"
+
+inherit autotools
+
+FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
+FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
+FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
+FILES_${PN}-dbg += "${libdir}/fwts/.debug"