aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorVinson Lee <vlee@vmware.com>2010-01-08 16:14:19 -0800
committerVinson Lee <vlee@vmware.com>2010-01-08 16:14:19 -0800
commitc10e9254a8d8a55825d047cf98b2608183c294ba (patch)
tree15837af1c8eb16f8e52bd613558bb8a7baf24089 /tests/CMakeLists.txt
parent9d011c7df9a84905351aa69a63d6b0feb59ee901 (diff)
CMake: Build mesa tests only on Linux.
The mesa tests currently do not build under MSVC or on Mac OS.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cdd3a4e1..1d6dfc99 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -6,6 +6,9 @@ add_subdirectory (general)
add_subdirectory (glean)
add_subdirectory (glslparsertest)
add_subdirectory (asmparsertest)
-add_subdirectory (mesa)
add_subdirectory (shaders)
add_subdirectory (texturing)
+
+IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ add_subdirectory (mesa)
+ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")