aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSergei Trofimov <sergei.trofimov@arm.com>2017-03-09 14:44:26 +0000
committerSergei Trofimov <sergei.trofimov@arm.com>2017-03-15 14:34:23 +0000
commit011fd684bdee096a7dc158df96c58a0d948b80e3 (patch)
tree9fbeb07fe195c5e133e4841bbe719c697351d25f /setup.py
parent6eb5c3681d5fbeb3f45e63f1603ae78e5c2ad4a1 (diff)
Skeleton job execution
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 0b9bdf04..4a9b43dd 100644
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,7 @@ scripts = [os.path.join('scripts', s) for s in os.listdir('scripts')]
params = dict(
name='wlauto',
- description='A framework for automating workload execution and measurment collection on ARM devices.',
+ description='A framework for automating workload execution and measurement collection on ARM devices.',
version=get_wa_version(),
packages=packages,
package_data=data_files,
@@ -72,13 +72,14 @@ params = dict(
maintainer_email='workload-automation@arm.com',
install_requires=[
'python-dateutil', # converting between UTC and local time.
- 'pexpect>=3.3', # Send/recieve to/from device
+ 'pexpect>=3.3', # Send/receive to/from device
'pyserial', # Serial port interface
'colorama', # Printing with colors
'pyYAML', # YAML-formatted agenda parsing
'requests', # Fetch assets over HTTP
'devlib', # Interacting with devices
- 'louie' # callbacks dispatch
+ 'louie', # callbacks dispatch
+ 'wrapt', # better decorators
],
extras_require={
'other': ['jinja2', 'pandas>=0.13.1'],