aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSergei Trofimov <sergei.trofimov@arm.com>2018-01-25 08:24:18 +0000
committerMarc Bonnici <marc.bonnici@arm.com>2018-01-25 10:50:02 +0000
commit1fe899fd7cf06e61f2b92e04998bf5e588128821 (patch)
tree8e56df373e3ae7eeb5bef52ada1e518bc92ccf10 /setup.py
parentdae4d9a9345da9ff10623343c9309accda047876 (diff)
Promote pandas to a mandatory dependency.
Pandas is already widely used in WA and devlib for fast numerical table manipulation in various instruments and output processors. Up to this point, it has been an optional dependency. Over the last couple of years, the package has become very wide spread, and is available in repos for virtually every major distro. There is now little reason not to require it as a mandatory dependency.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fe240428..e7e9b7b2 100644
--- a/setup.py
+++ b/setup.py
@@ -80,9 +80,10 @@ params = dict(
'devlib', # Interacting with devices
'louie', # callbacks dispatch
'wrapt', # better decorators
+ 'pandas>=0.13.1', # Data analysis and manipulation
],
extras_require={
- 'other': ['jinja2', 'pandas>=0.13.1'],
+ 'other': ['jinja2'],
'test': ['nose', 'mock'],
'mongodb': ['pymongo'],
'notify': ['notify2'],