aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYongqin Liu <yongqin.liu@linaro.org>2015-01-03 17:46:21 +0800
committerYongqin Liu <yongqin.liu@linaro.org>2015-01-03 17:46:21 +0800
commitcf7013d6e23f0a0da3bcae5fb9d8e20639b1d21f (patch)
tree4888505a53fc2070d376945391ae48bbee333166 /setup.py
first commit
Signed-off-by: Yongqin Liu <yongqin.liu@linaro.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py71
1 files changed, 71 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..bdfdf87
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,71 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2010, 2011 Linaro
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name='lava-android-test',
+ version=":versiontools:lava_android_test:",
+ author='Linaro Validation Team',
+ author_email='linaro-dev@lists.linaro.org',
+ url='https://launchpad.net/lava-android-test',
+ description='LAVA android test execution framework',
+ long_description=open("README").read(),
+ packages=find_packages(exclude=['tests']),
+ license="GNU GPLv3",
+ test_suite='tests.test_suite',
+ entry_points="""
+ [console_scripts]
+ lava-android-test=lava_android_test.main:main
+ [lava_android_test.commands]
+ version=lava_android_test.commands:version
+ list-devices=lava_android_test.commands:list_devices
+ list-tests=lava_android_test.commands:list_tests
+ list-installed=lava_android_test.commands:list_installed
+ list-results=lava_android_test.commands:list_results
+ install=lava_android_test.commands:install
+ uninstall=lava_android_test.commands:uninstall
+ run=lava_android_test.commands:run
+ run-custom=lava_android_test.commands:run_custom
+ run-monkeyrunner=lava_android_test.commands:run_monkeyrunner
+ parse=lava_android_test.commands:parse
+ parse-custom=lava_android_test.commands:parse_custom
+ show=lava_android_test.commands:show
+ rename=lava_android_test.commands:rename
+ remove=lava_android_test.commands:remove
+ extract-attachments=lava_android_test.commands:extract_attachments
+ """,
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 2.6",
+ "Topic :: Software Development :: Testing",
+ ],
+ install_requires=[
+ 'lava-tool >= 0.2',
+ 'lava-dispatcher',
+ 'pexpect',
+ 'versiontools >= 1.4',
+ ],
+ setup_requires=[
+ 'versiontools >= 1.4'
+ ],
+ zip_safe=False,
+ include_package_data=True)