summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..28fe0d4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with python2
+
+.PHONY: override_dh_auto_test
+override_dh_auto_test:
+ # Run the bundled tests when building the package
+ LC_ALL=C python setup.py test
+
+.PHONY: override_dh_auto_clean
+override_dh_auto_clean:
+ # Remove everything else
+ dh_auto_clean
+ # Remove build directory with sphinx files
+ rm -rf build