aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola <kerolasa@iki.fi>2014-11-25 21:16:20 +0000
committerAlexandra Yates <alexandra.yates@linux.intel.com>2014-11-25 15:04:41 -0800
commit98f5452d6ae0294a5e2c5211ebc95c4e74ab75c4 (patch)
treeb5d853baff05645625586c44ad2793c93a020f37 /configure.ac
parentbf3757e4718217213b4b8411966a1318a0c5014d (diff)
configure: use autoconf-archive ax_cxx_compile_stdcxx_11.m4
Ensure the powertop is compiled C++11 compliant compiler. That allows project contributors to use features from the latest standard without hesitation are they allowed in this project. The idea is to grant greater liberties to upstream in cost of a dependency to downstream. Notice that adding a downstream dependency to C++11 compliant compiler is not outrageously unreasonable. Many of the C++11 features has been supported quite a while. That said use of some features, such as attributes (N2761), may still make maintainers to be unhappy if the case is not justified well enough. Reference: http://en.cppreference.com/w/cpp/compiler_support Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b9ee05a..79ea055 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AC_PROG_CC
AC_PROG_INSTALL
AM_PROG_CC_C_O
GCC_FORTIFY_SOURCE_CC
+AX_CXX_COMPILE_STDCXX_11([noext], [mandatory])
# Checks for libraries.
AX_PTHREAD([