summaryrefslogtreecommitdiff
path: root/libc/configure.in
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-05-12 15:44:41 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-05-12 15:44:41 +0000
commit62eb53f68d92687a028f3c515489b30e3df1d979 (patch)
tree7fcf1c95d89caecbbff5d932778f04670c151c52 /libc/configure.in
parentc29b18b38ccefba22c13b33dd801acba0ae92523 (diff)
Merge changes between r18392 and r18519 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@18520 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/configure.in')
-rw-r--r--libc/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/libc/configure.in b/libc/configure.in
index 00b024b57..8ba667140 100644
--- a/libc/configure.in
+++ b/libc/configure.in
@@ -257,6 +257,17 @@ else
fi
AC_SUBST(libc_cv_nss_crypt)
+AC_ARG_ENABLE([obsolete-rpc],
+ AC_HELP_STRING([--enable-obsolete-rpc],
+ [build and install the obsolete RPC code for link-time usage]),
+ [link_obsolete_rpc=$enableval],
+ [link_obsolete_rpc=no])
+AC_SUBST(link_obsolete_rpc)
+
+if test "$link_obsolete_rpc" = yes; then
+ AC_DEFINE(LINK_OBSOLETE_RPC)
+fi
+
# The way shlib-versions is used to generate soversions.mk uses a
# fairly simplistic model for name recognition that can't distinguish
# i486-pc-linux-gnu fully from i486-pc-gnu. So we mutate a $host_os