aboutsummaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorTobias Burnus <tobias@codesourcery.com>2020-07-26 07:20:24 +0200
committerTobias Burnus <tobias@codesourcery.com>2020-07-26 07:20:24 +0200
commit2e764ae1d666002b136726e6548481013527197d (patch)
treeb73073eb2609597f124c1ca348192272c6749c07 /libgfortran/configure.ac
parent2ab2694476c9fc87f0cabf7021af4624eb62c87c (diff)
libgfortran: Skip integer-kind=16 check for amdgcn
libgfortran/ChangeLog: PR target/96306 * configure.ac: Add LIBGOMP_CHECKED_INT_KINDS and LIBGOMP_CHECKED_REAL_KINDS and use it for to skip integer kind=16 checks for amdgcn. * Makefile.am (kinds.h, selected_int_kind.inc, selected_real_kind.inc): Pass them on. * mk-kinds-h.sh: Takes to-be-check kinds as argument. * mk-sik-inc.sh: Likewise. * mk-srk-inc.sh: Likewise. * Makefile.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 4109d0fefae..8961e314d82 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -216,6 +216,19 @@ AM_CONDITIONAL(LIBGFOR_USE_SYMVER_SUN, [test "x$gfortran_use_symver" = xsun])
AM_CONDITIONAL(LIBGFOR_MINIMAL, [test "x${target_cpu}" = xnvptx])
+# Some compiler target support may have limited support for integer
+# or floating point numbers – or may want to reduce the libgfortran size
+# although they do have the support.
+LIBGOMP_CHECKED_INT_KINDS="1 2 4 8 16"
+LIBGOMP_CHECKED_REAL_KINDS="4 8 10 16"
+
+if test "x${target_cpu}" = xamdgcn; then
+ # amdgcn only has limited support for __int128.
+ LIBGOMP_CHECKED_INT_KINDS="1 2 4 8"
+fi
+AC_SUBST(LIBGOMP_CHECKED_INT_KINDS)
+AC_SUBST(LIBGOMP_CHECKED_REAL_KINDS)
+
# Figure out whether the compiler supports "-ffunction-sections -fdata-sections",
# similarly to how libstdc++ does it
ac_test_CFLAGS="${CFLAGS+set}"